Recent filters menu is purged from time to time


I’ve notice that since 5.5 – recent filters menu purged its content after some time. I tried to find out the algorithm to reproduce the problem but didn’t succeed. Does anybody also see the issue or I just so lucky?

There is a new Bookmarks submenu that is also very useful but it’s not the same and Recent filters is very useful for me.

Debian testing amd64, pv from the

@gbug if you delete your settings files or choose Edit->Reset to Default settings, the entries in the Recents submenus will be deleted. Also, when you change to another version of ParaView, certain GUI-application-based settings are not carried over from previous versions. This includes the recent files menu items. That could explain why your recent menu items have been purged.

No, the problem is not that recent filters purged when I install another version of PV or playing with settings file. The problem happens without any additional actions from my side, same version, same settings, but after several restarts of PV the submenu is empty.

Interesting. Nothing should have changed in 5.5 or later to affect how Recent filters are kept. I just tried relaunching ParaView five times and the recent filters remained. If you notice a particular sequence of actions lead to the missing recents, please post those actions here so I can attempt to reproduce. Thanks.

And, Gena, if you do remove your configuration files (with the Reset to Default Settings mentioned above), please keep copies of the .config files. Kitware will want them to try to debug what is going on.