Run Vizualiser from ParaView

I want to run Visualizer from ParaView in the terminal (I use Mac). I follow this step by step: Documentation | Visualizer

–content ./Resources/web/visualizer/www/
–data $PWD/data
–port 8080

After writing this section above nothing happens. I don’t get any feedback…
How should I go forward with this?

Thank you in advance!

Regards, Victoria

Which version of ParaView are you running?

You also don’t get any output? Like “Starting Factory”?

Did you approve the app so macOS allow you to run it?

Version ParaView-5.8.0

No, I don’t get any output at all.

Yes, I have approved the app. I can see that I don’t have macOS Big Sur on my laptop… I will update this and see if it works

I’m not sure what could be happening on your machine.

I think that with 5.8, you can run pvpython -m paraview.apps.visualizer --data ~/.

And list the available apps to by running pvpython -m paraview.apps -l

My friend works on Windows. Please see attached image. Do you have any idea how to solve these errors? (Version ParaView 5.8.0)


I downloaded ParaView 5.9.0 and Visualizer localhost8080 works! :slightly_smiling_face:

I want to connect ParaView and Visualizer, what should I write in “Choose Server Configuration”? As you can see there is also a problem with Python library, see attached image.

If you want both Visualizer and ParaView Qt connected to the same server you will have to:

  • start pvserver --multi-client
  • connect visualizer to your pvserver (you have some connect arg that you can use
  • connect ParaView Qt to that pvserver

But you are on the fringe of what is possible and I’m not sure how stable it will be…

Thanks. I tried with pvserver --multi-clients and wrote the server configuration in Paraview (first image). As soon as I run http://localhost:11111/ i get these errors.

Yes that is expected. The pvserver protocol has nothing to do with http. You can only connect your browser to a pvpython ... process. But that process can connect to a pvserver by using those arguments. In the same way, the ParaView Qt client can not connect to a pvpython ... process. I hope that clarify some of the confusions.