ScreenShots interpolations


I do screenshots of slices in Grayscale in Paraview. I set up a transparent background, and when I read my images (with Matlab for example), I see that the pixels surrounding my object are interpolated between the gray value of my object and the “0” of the background, which distort my results.
Do you know how I could disable such an interpolation ? I already tried to disable the light tool kit, but it’s not sufficient.
Thank you very much for your answer,


Corentin Calbrix

PointDataToCellData ?

Please share a screenshot.

Thanks for the response. My datas are already in CellData when I make my slices. Here is a screenshot where you can see the interpolations between my objects and the background. My gray datas should be around 128, and are interpolated at around 50.

My guess is that you are seeing effects from antialiasing in the rendering. You can try turning off the FXAA feature.

Go to ParaView settings, click on the Render View tab, and turn off the Use FXAA feature.

1 Like

thank you very much !! It works perfectly now, I do not have any interpolations anymore.