seeking suggestions for our use case

Hi all,

We are planning to use ParaView with Catalyst for our case and I am seeking some suggestions.

We want to visualize a 3D object (Computed Tomography), represented by 3D metric, pixel by pixel. Basically 4D because we have time dimension as well, means that we want to “play” 3D movie and the FPS is about 1/10 (one 3D every about 10 seconds).

What is the best way to stream data from our code to ParaView, after reading the tutorial slides, I feel that Catalyst can do the job. Does it make sense? What type of machine/GPU do we need to achieve our goal. The original image size is 2.5k x 2.5k x 256 but we can reduce it to 1k x 1k x 256 if visualizing needs much more than 10 seconds.

Is there a hands-on example?


Catalyst can do that, you’re right.

See this examples (from PV source code):


  • FEDriver.cxx and FEDataStructure simulate your code
  • FEAdaptor shows how to put your data into a VTK class and send it to Catalyst Pipeline.
  • Catalyst script used to configure pipeline. It can be generated through ParaView GUI (Catalyst menu). To use the streaming feature, active LiveVisualization in the script.

The machine you already use for your code should be enough, at least if you use surface rendering. For volume rendering you may need a GPU …

Hi Nicolas,

Thanks for your response.

Instead the cxx example, we tried the Python version that did the same thing as the one you pointed to me I believe.

But I run into problems. If I use the latest paraview(5.7 on MACOS) and run with
it says “ImportError: No module named vtkParallelCorePython”
after adding </Applications/> to PYTHONPATH
it gives " import vtkPVClientServerCoreCorePython as CorePython
ImportError: No module named vtkPVClientServerCoreCorePython"

I then turn to use an old version as said v4.2

I got another error:
“from paraview.modules import vtkPVCatalyst as catalyst
ImportError: No module named modules”

Do you know if there is an up-to-date example for the lastest paraview? if not, which version should work with the example?


problem resolved…

How did you fix it ?

it seems that ParaView (at least for MACOS) changed its folder structure. So, if there are missing python package, you need to go back to the ParaView folder, find the package and add its path to PYTHONPATH or

change the import ** to from from paraview.modules import ** there are multiple lines you need to update, simply run it, get the error and change it. I personally like the last solution more.

1 Like