Starting pvserver with mpirun

I have extracted the paraview binaries from the latest release
I can view remotely using pvserver + paraview, but I cannot start pvserver in parallel. It tries to open the same port multiple times, which I understand is typical if paraview is not compiled with MPI. However this is the kitware release (I also tried ParaView-5.9.1-MPI-Linux-Python3.8-64bit with the same result) and I have a functioning openmpi on the server (it runs openfoam in parallel). I added the openmpi library (usr/lib/x86_64-linux-gnu/openmpi/lib/openmpi3/) to LD_LIBRARY_PATH but this did not help. Any ideas?
The OS is Ubuntu 22.04 and the graphics card is NVIDIA Quadro P2000.

Try using mpich instead of openmpi. As I recall the binaries are mpich ABI compatible as are many, but not all MPI’s.

ParaView in indeed built against mpich and is compatible with other MPI implementations that follow the mpich compatibility initiative. OpenMPI binaries are not compatible.

If you wish, you can use the mpiexe that ships with the official binaries, but that may take some configuration on your system to use it.