Stream tracer greyed out

Hi when i run my vtu file on paraview stream tracer is greyed out. I created my file on Freefem. İ need to great stream lines on a slice of 3d velocity . How can I do?

please share your data

u.vtu (108.0 KB)

Your data does not contain any vectors

How can I add ?

Not sure what you mean. You have u, scalars1 and scalars2, do you want to create a 3D vector fromt them ?

Yes. İ obtained this data from freefem as solution 3d velocity. İ need to get its streamlines but i don’t know how to add vectors to the data

Add a MergeVectorComponents filter and configure it as wanted

Thank you I’m going to try.

Hi to get this which filter did you use? İ did merge filter components and select stream tracer. Mine didn’t turn out like this

Please share a screenshot

The first one is after i applied stream tracer.
The second one is after i applied merge vector components

Here is what I did:

  • Open ParaView
  • File → Open → u.vtu, Apply
  • Filters → MergeVectorComponents, XArray = u, YArray = scalars2, ZArray = scalars3, Apply
  • Filters → StreamTracer → Apply

İ did the steps. This happened

Also i need to display streamlines generated by line segment source { (0.5,0.5,z) :0<z≤1} how can I do it

Which is good ?

Yours is better. İ want to get like this how can I do it

  • Click on the “MergeVectorsComponent” in the pipeline browser
  • Show it by clicking the eye
  • Set opacity to the representation to 0.2

You may want to read the tutorial though: Self-directed Tutorial — ParaView Documentation 5.11.0 documentation

Well thank it worked. My main aim is too get a vote like the one I attached now. How can I do
İt was said that “display streamlines generated by line segment source { (0.5,0.5,z) :0<z≤1}”