Streamline with Glyph in 3D animation

Any one know how to create streamline with Gluyph animation in 3D from steady state OpenFoam run.


Alex Lee

  1. Create the streamlines as you normally would.

  2. Add a Contour filter to the streamline (third toolbar, second button from the left).
    2.a. Change the Contour By property to IntegrationTime.
    2.b. Press Apply.
    This little trick will create a point on each streamline at a particular time in the particle advection simulation that created the streamlines.

  3. Open the Animation View (View -> Animation View)
    3.a. On the bottom row, select the contour filter in the first chooser box and Isosurfaces in the second chooser box. Then hit the blue plus button at the left.
    3.b. Make sure Mode is set to Sequence and change No. Frames to 100.
    3.c. Hit the play button in the VCR controls (green triangle in the top toolbar). You will see the dots animate over the streamlines.
    3.d. You can adjust the speed of the animation by changing the No. Frames.

  4. If you want to see glyphs instead of dots, just add the glyph filter to the output of the contour filter.

from :

1 Like


Is it possible using this method to export the 3D glyphs for each timestep? I’m trying to do this using the .PLY format, but I can only seem to get the first timestep repeated for each of all the timesteps (using the “Write Time Steps” option). Yet, if I export individual frames by manually moving to the correct frame in the “Animation View” it seems to work. This work around is rather cumbersome for doing larger studies though.

Any ideas?

How are you saving the data ? Which button ?

Thanks alot Mathieu!

1 Like

Whilst the “Glyph” is selected in the Pipeline Browser, I am going to “File” > “Save Data” then using the PLY file format. In the “Configure Writer (PPLYWriter)” window, I have got “Write Time Steps” selected, “_%.3d” as the suffix and “Enable Coloring” selected.

This just outputs the same PLY file for each timestep, different sequential names, but the same file size and content.

I hope that makes sense.

Which version of ParaView are you using ?


Unable to reproduce.


  • unzip (3.9 MB)
  • Open can_*.ply as a file series, Apply
  • Check animation is working
  • File -> Save Data, Check Write time steps, Save
  • close ParaView, open ParaView
  • Open the new file_* as a file series, Apply
  • Check animation is working

I can confirm that your steps work correctly on my machine.

I am trying this method on the same dataset that I shared in this thread:

Would you mind trying this method on that too?