Streamtracer changes color

I have created streamlines using the Stream-tracer filter. I defined the lines to be black.
However, after I apply the transform filter the lines get changed to white. Does anybody knows why this is happening? The lines are plotted over a background that is dark blue. Does Paraview automatically change the color?
Thank you.

Are you using solid color coloring ?

Yes, I am using solid color.

Solid color coloring is not conserved when applying a filter and when the datatype changes. To obtain this behavior, you have to do the following :

  • Edit -> Settings -> General -> Inherit Representation Properties
  • Before Adding a transform filter, add a “Pass Arrays” filter, and uncheck all arrays.

Thanks for the tip Mathieu. I didn’t know that existed. NOTE - this is an advanced feature. In Settings, be sure to click the little gear upper right of the Settings dialog.

I also didn’t need to add the Pass Arrays filter. All I did was change the setting you point to, add disk_out_ref.exo, add the stream tracer, change color to black, and add a transform. Worked perfectly.

1 Like


Thank you for your response.

Sorry I don’t know where to find this:

  • Edit -> Settings -> General -> Inherit Representation Properties
    In the Edit menu I don’t have Settings.

Could you please let me know where I can find exactly that path?

Thank you.

Is it possible to increase the thickness of the streamlines?

I could not find it yet.


With regards to Edit/ Settings, I bet you are on a Mac. On Mac we use the OS X convention, and it is under ParaView/ Preferences (if memory serves.).

With regards to thickness of streamlines, this can be changed using the Properties tab. Generally speaking, look here first. Also, frequently state like this is hidden to keep the Properties tab somewhat reasonably sized. Click the Advanced icon (little gear to the right of the search window, top of the Properties tab). You are looking for “Line width”.

A better solution is to use the Tube filter on the streamlines filter.