I’m using StreamTracerWithCustomSource with the seed input being my fluid inlet face, no matter what settings I change only 2 stream lines reach the outlet ;-( Can anyone suggest a solution?

Use the outlet as the custom source. The default stream tracer behavior is to trace forwards and backwards in the vector field, so you should get a lot of streamlines reaching the outlet this way.

Hi Cory,
If I use the outlet, & trace backwards then very few reach the inlet, if I trace both forwards & backwards a few reach the inlet but a whole bunch race out of the outlet where my fluid body ends.

Sounds like a complicated flow! The only other suggestion I have is to use a regular Stream Tracer with the “High Resolution Line Source” or “Point Source” placed somewhere in the middle of your fluid body.

Hi Cory,
Thanks for the suggestion, and taking the time to try and help.

Have you looked at the ReasonForTermination array to see why the streamlines are terminating? You can ? button for the filter to see what the numbers correspond to for the termination criterion.

Hi Andy,
How do I look at the ReasonForTermination array?

It’s a cell data array that’s output by the stream tracer filter. You can either pseudo-color by it in the render view or look at it in a spreadsheet view.

I get values of mostly 6 (velocity was lower than the Terminal Speed input value) and a few 1 (streamline crosses the exterior boundary of the input dataset). I think know what they mean but not sure how I can improve matters?

The Terminal Speed parameter is an advanced filter option which means you need to clock on the gear looking button to be able to adjust it. By default it’s set to 1e-12. For termination values of 1 the streamline should be exiting the domain. If not, it’s likely that the grid cells aren’t properly connected.