superbuild for 5.7.0 fails on ARM system - Could not configure LLVM for the target system processor aarch64

I’m trying to build 5.7.0 using the superbuild on an ARM-based aws graviton system, but get the following errors:

cmake -D CMAKE_INSTALL_PREFIX=/data/paraview/$pvVer -D mesa_USE_SWR=OFF -D ENABLE_llvm=ON -D ENABLE_pythondateutil=ON -D ENABLE_pythonsix=OFF -D ENABLE_numpy=OFF -D ENABLE_paraview=ON -D ENABLE_qt5=OFF -D ENABLE_python3=ON -D ENABLE_python=OFF -D ENABLE_osmesa=ON -D ENABLE_mpi=ON -D USE_SYSTEM_python3=ON -D USE_SYSTEM_mpi=ON ./paraview-superbuild/

– Determined source version for paraview: 5.7.0
CMake Error at projects/unix/llvm.cmake:20 (message):
Could not configure LLVM for the target system processor ‘aarch64’.
Call Stack (most recent call first):
superbuild/cmake/SuperbuildMacros.cmake:735 (include)
superbuild/CMakeLists.txt:145 (_superbuild_discover_projects)

– Configuring incomplete, errors occurred!

Really not expert enough to find the issue, but I am able for example to build fully with 5.9.0. Anyone have suggestions?

A̶f̶a̶i̶k̶ ̶A̶R̶M̶ ̶i̶s̶ ̶n̶o̶t̶ ̶o̶f̶f̶i̶c̶i̶a̶l̶l̶y̶ ̶s̶u̶p̶p̶o̶r̶t̶e̶d̶.̶

In any case, disable mesa and llvm in your superbuild to work around this issue.

FYI @ben.boeckel

That’s interesting, because a spack install of 5.7.0 works well on arm, including with mesa/llvm! I’m trying to reproduce the install via the superbuild which fails.


The 5.7.0 version of ParaView’s superbuild probably has an LLVM that is too old to support aarch64. Spack is likely using a newer LLVM.

For the record, 5.7.0 contains LLVM 7. I don’t know if we pass the right arguments to it for aarch64.

Turned out to be a simple issue, which I reported. Linking here in case someone else with this issue comes across this post.

There has been a lot of work on Superbuild and ParaView from 5.7.0 to 5.9.0 for ARM processors/OS’s. Maybe try 5.9.0?

1 Like