Temporal Interpolator Filter Removes Time Steps


I’m have a time variant data set that I want to apply Temporal Interpolator Filter on to make it smoother. When I apply the filter the time steps get removed from the ParaView time bar.
I want to be able to save each frame as an individual image.

Here is a screen shot before applying the filter:

And here is how it looks after applying the filter:
Screen Shot 2021-03-22 at 2.24.24 PM

  1. Is there a way to tell paraview to double the original time steps to reflect the interpolation impact?
  2. And is there a way to save one image per time step?

I tried applying the extract time steps filter after the Interpolator filter but it shows the range to be 0 to -1.

Simple use the Animation View to set the number of timesteps you need.

Here are a couple of other solutions.

  • Update to ParaView 5.9. There is an update to Temporal Interpolator that preserves the timesteps. There is an option to the Temporal Interpolator named Resample Factor to set how many new timesteps to interpolate after each original timestep. Set it to 2 to double the number of timesteps.
  • In versions pre ParaView 5.9, try setting the Discrete Time Step Interval option of Temporal Interpolator. If set greater than 0, the Temporal Interpolator will create a time step at those intervals per simulation time. For example, in the can.ex2 example data set, the simulation has created time steps at about every 1e-4 seconds. You can set Discrete Time Step Interval to half that (5e-5) to double the number of timesteps.