Temporal interpolator screws up Resample with dataset

Hello, I ran into some quite disturbing behaviour using ParaView 5.9.0 on a Linux machine.
My solution file contains a flow field from Navier-Stokes, time-dependent. I want to compute fluxes across a given surface over time, so I put together a pipeline like so:

  1. extract the relevant blocks
  2. append them
  3. generate surface
  4. generate surface normals
  5. use Calculator to compute the fluxes
  6. resample with dataset to the surface I’m interested into
  7. integrate variables

Long-story short: I thought it was cool to add temporal interpolator to sample data at regular times since I use adaptive time stepping, but then I realised that something was off.
Upon closer inspection, I saw that using a temporal interpolator somehow messes up with the whole pipeline, most likely with the Resample with dataset filter.
The symptom is that some time steps contain garbage data, but not always: if I go back and forth, it will give different results [possibly the correct one].

I attach a clip to show the issue. demo.mkv (1.0 MB)


Are you able to identify which timesteps fails and reproduce it without using time at all ?
What if you add the temporal interpolator after the resample ?

It’s not a single time step that fails, it’s all of them, at random. In fact, I plotted data over time and from the resulting plot I could see that around 30/40% of the data points were garbage.

I haven’t tried interpolating after resampling, I can try that and report back.

Adding a temporal interpolator only to the resample with dataset filter at the end of the pipeline seems to work as expected.

1 Like