Transform all input vectors


#1

I’ve noticed that when a dataset is transformed, not only the coordinate are scaled but also vector data such as the velocity field.

I’ve tried to turn off the transform all input vectors option but nothing changed.

Any hint?


(Mathieu Westphal) #2

The Transform filter will always transform the array currently identified as the “Vectors” in a VTK sense.
A very simple work around is the following :

  • Open ParaView
  • Open your dataset, Apply
  • Add a calculator filter, click on “Vectors”, select your vector, Apply
  • Add a transform filter, configure it, uncheck “transform all input vectors”, Apply
  • your vector has not been transformed.

#3

Hi Mathieu.

Thanks a lot for the info and the workaround.

Much appreciated.