Two questions on 1. the pvti format data and 2. Paraview build

Dear developers,

  1. I connected the Paraview by using pvserver command. I can do ploting (no problem) , but I can not save the data in pvti format. How to fix it, please?
  2. Yestoday, one developer told me that I have to rebuild the paraview on PARAVIEW_USE_MPI CMake flag.
    Then I do step by step following the guide on
    Finally, I meet a problem. There is only one key when I reach the step “ccmake …/paraview”. How to fix this problem?
    Thank you very much.

Just press “c” to start configuring your build and then turn on PARAVIEW_USE_MPI.

Thanks a lot (I suppress the “c”). I realize the cmake on our server is too old.
When I installed cmake3, it becomes ok now.

Dear developer,
When I turn ON the MPI option below and it begins to configure. When It reaches about 80-90%, an error has been reported. Does it important or I can neglect it? Thanks a lot.

Make sure that OpenGL is installed on your system and the variable OPENGL_INCLUDE_DIR points to its include directory (usually contains gl.h). If not, you should install it first and check the value of the mentioned variable afterwards.


@Zhongwei_Yang, To answer your first question, the reason why you cannot write your data in the pvti format is because you can only write “image” data (uniform rectilinear grid) in that format. Your data is not image data. The output of the clip filter is unstructured grid. You have to write out unstructured grid data in a format that can handle unstructured grids such as vtu or pvtu.

If you really want to write out your data in pvti files as a dense regular grid, you have to convert your data to image data. The best way to do this is probably the “Resample to Image” filter. However, I think this filter was added after ParaView 4.4, so you probably have to upgrade if you want to do this.

Thank you very much for the detailed information.