unable to read XDMF Set or Subset

Trying to select a portion on the grid and assign different values to. Tried using Set and SubSet both fail.
Been reading the documentation of both XDMF and Paraview and tried everything but to no avail. From the 3 readers that ParaView offers, only the first reads the set or subset name, but not displaying any data. Other readers crash.
Very small example attached for both Set and SubSet (commented out). In this example, intentionally selecting all cells, but an attempt to select just some also fails miserably.
3dCoRect_export.xdmf (2.0 KB)

Please help, Thanks

Here is a valid .xmf file if that helps you :

testFile.xmf (2.0 KB)

Thank you for your help Mathieu, but this is not addressing my problem.
The testFile you attached is not using Set nor SubSet.

Are these supported?

has anyone been able to work with XDMF sets or subsets?

I suspect we just don’t have the support for it implemented in the Xdmf readers we have. I’m not familiar enough with libxdmf or the code in the reader itself to know whether it’s even trying or not though.