The vectors are in all directions in this 3 dimensional slice image. I want the vectors only in the plane, how do I do that ?

Calculator with an expression like:

vec_x*iHat + vec_z*kHat

I tried an this is what I got It is still projecting out of the plane. I want it with the plane and nonw of them outside
, I am a beginner so help me out.

you vector is not named vec, it is named velocity,
the formula should be:

velocity_x*iHat + velocity_z*kHat

Also you should apply the glyph after the calculator.

Please read this excellent ParaView Tutorial that @Kenneth_Moreland has put together and updated throughout the years.

Okay thanks a lot.

Even after that it seems to come out, I will try checking out the tutorials but I need help. Should I do it in 2D ? or how do I get the vectors in a plane for a slice in this 3D data file ?

put your glyph on the calculator, not the celldatatopointdata

I tried that too, it is still the ssame, it comes out of the plane. What shall I do ?

Orient with “Results”, not with velocity.

Yeah I have tried that thanks but this isn’t what I wanted, they are all in one direction now. I want the previous image without the projections but the same direction. Thanks for helping me out but as I am a beginner I need help.

You’re still not orienting with Results. Instead, you have turned off orientation (which is why the arrows are no longer pointing in different directions).

In the Properties panel, change the Vectors combobox (under Active Attributes) to Results (right now they are still set to velocity), and click on the Orient checkbox (right below it under Orientation).

There is only velocity in the vectors combobox
not an like u said, There was no results in the active

I am using 2Dglyphs. I want the arrows to show better, as you can see some arrows are represented like usual lines and not arrows. I want to change the thickness and appearance. I tried 3D glyphs but they seems to go out of the plane. I want the same image with bette appearance of arrows. Help me with it.