[Virtualbox Debian] Loguru caught a signal : SIGABRT

Hi everyone,
I’m new on gnu-linux, vm…
I did’nt find any answer to my problem so I hope my question was not asked previously.

The VM was built lats week :

  • Oracle VM Virtual box
  • Debian 9 64 bit
  • 8 Go memory
  • Display : 16 Mo video memory / graphic controller : VMSVGA
  • Gnome
  • (don’t know what else you need to help…)

Paraview should have been installed together with the software I need to use (I used a .run file).

I get the following issue :


Loguru caught a signal: SIGABRT
Stack trace:
32 0x5631e24e3f1a paraview(+0x7f1a) [0x5631e24e3f1a]
31 0x7f99d8dde2e1 __libc_start_main + 241
30 0x5631e24e3c03 paraview(+0x7c03) [0x5631e24e3c03]
29 0x5631e24e8852 paraview(+0xc852) [0x5631e24e8852]
28 0x5631e24e4c19 paraview(+0x8c19) [0x5631e24e4c19]
27 0x7f99d8a47001 pqParaViewBehaviors::pqParaViewBehaviors(QMainWindow*, QObject*) + 1041
26 0x7f99d89be23a pqAlwaysConnectedBehavior::pqAlwaysConnectedBehavior(QObject*) + 298
25 0x7f99d89be0a8 pqAlwaysConnectedBehavior::serverCheck() + 136
24 0x7f99d7c11385 pqObjectBuilder::createServer(pqServerResource const&, int) + 197
23 0x7f99d6ed9908 vtkSMSession::ConnectToSelf(int) + 104
22 0x7f99d65daa2b vtkProcessModule::RegisterSession(vtkSession*) + 139
21 0x7f99d0ef9d5e /home/user/salome-hydro/Salome-V2_2-s9/prerequisites/Paraview-580/lib/libvtkCommonCore-pv5.8.so.1(+0x360d5e) [0x7f99d0ef9d5e]
20 0x7f99d0df1919 vtkCallbackCommand::Execute(vtkObject*, unsigned long, void*) + 25
19 0x7f99d73e148c /home/user/salome-hydro/Salome-V2_2-s9/prerequisites/Paraview-580/lib/libvtkGUISupportQt-pv5.8.so.1(+0x3f48c) [0x7f99d73e148c]
18 0x7f99d73f0e27 /home/user/salome-hydro/Salome-V2_2-s9/prerequisites/Paraview-580/lib/libvtkGUISupportQt-pv5.8.so.1(+0x4ee27) [0x7f99d73f0e27]
17 0x7f99cf4f222f QMetaObject::activate(QObject*, int, int, void**) + 1503
16 0x7f99d7c8e259 /home/user/salome-hydro/Salome-V2_2-s9/prerequisites/Paraview-580/lib/libpqCore-pv5.8.so.1(+0x148259) [0x7f99d7c8e259]
15 0x7f99d7c89961 pqServerManagerObserver::connectionCreated(int) + 49
14 0x7f99cf4f222f QMetaObject::activate(QObject*, int, int, void**) + 1503
13 0x7f99d7c5e471 pqServerManagerModel::onConnectionCreated(int) + 769
12 0x7f99d7c887d2 pqServerManagerModel::serverAdded(pqServer*) + 50
11 0x7f99cf4f222f QMetaObject::activate(QObject*, int, int, void**) + 1503
10 0x7f99d8a0a3a3 pqDefaultViewBehavior::onServerCreation(pqServer*) + 67
9 0x7f99d6df1832 vtkPVSessionCore::GatherInformation(unsigned int, vtkPVInformation*, unsigned int) + 34
8 0x7f99d6df16c3 vtkPVSessionCore::GatherInformationInternal(vtkPVInformation*, unsigned int) + 115
7 0x7f99cbd5bb89 vtkPVRenderingCapabilitiesInformation::CopyFromObject(vtkObject*) + 9
6 0x7f99cbd5bb48 vtkPVRenderingCapabilitiesInformation::GetLocalCapabilities() + 408
5 0x7f99d4632a95 vtkOpenGLRenderWindow::SupportsOpenGL() + 1253
4 0x7f99d46dd5c2 vtkXOpenGLRenderWindow::WindowInitialize() + 18
3 0x7f99d46e0f61 vtkXOpenGLRenderWindow::CreateAWindow() + 1921
2 0x7f99d8df242a abort + 362
1 0x7f99d8df0fff gsignal + 207
0 0x7f99d8df1060 /lib/x86_64-linux-gnu/libc.so.6(+0x33060) [0x7f99d8df1060]
( 2.068s) [paraview ] :0 FATL| Signal: SIGABRT
Abandon


Has anyone any idea to solve it please ?

you want to use mesa.

what is the output of glxinfo | grep Vendor ?

I’m not sure to understand…
Please find attached the last try.

Please use paraview directly instead of salome.

glxinfo is an executable from mesa-utils package, you need to install it.

new try…

You need to use mesa instead of VMware provided OpenGL.

How do you do that ?

Can you try paraview --mesa ?

I get same ansmwer : “bash: paraview : commande introuvable”

Meanwhile, I increased the video memory to 64 MB

You need to download ParaView then:

https://www.paraview.org/download/

ok, thanks, I’ll try to find which python/paraview/… versions they use/need, etc. and then download

Hello,

Chiming in to remark I have similar errors even with a self-compiled version of ParaView (over a range of versions, including 5.8), on a Debian-9 based Laptop (with EDF packages) and even in some cases using OSMesa, on a Debian 9-based cluster.

I don’t have these issues on my personal Arch-Linux based laptop (using a recent build of ParaView 5.9, but I update and rebuild very few weeks).

I tried to investigate this under a debugger once, and it seems there is an attempt to initialize the OpenGL environement in the exit sequence.

I could try to get back into this to provide more details or stack traces.

Best regards,

Yvan

This looks like an issue I saw recently. When building ParaView, be sure to set the CMake variable OpenGL_GL_PREFERENCE TO “LEGACY”.

You can do this from the command line with

cmake -DOpenGL_GL_PREFERENCE:STRING=LEGACY .

ParaView requires the LEGACY option for OpenGL rather than the default “GLNVD” - that should get you past this crash in vtkXOpenGLRenderWindow::CreateAWindow() .

Note that ParaView itself doesn’t care much. Certain platforms (here, Debian) seems to care very much. I use GLVND just fine on Fedora for instance. I suspect newer Debian is fine too.

Hello,

Thanks fo the info. I just tried this on Debian 9 (with EDF packagages, which may include a more recent Linux kernel and NVIDIA drivers) with ParaView 5.8.1, and still get the same error, with the following stack trace, using either own build instead of a Salome build, (but with Salome-provided packages for prerequisites such as OSPray):

Loguru caught a signal: SIGSEGV
Stack trace:
4 0x7fd688621f07 /usr/lib/x86_64-linux-gnu/libGL.so.1(+0x83f07) [0x7fd688621f07]
3 0x7fd688dbb0df XextAddDisplay + 79
2 0x7fd697babc22 XInitExtension + 50
1 0x7fd697bb808d XQueryExtension + 45
0 0x7fd69c835060 /lib/x86_64-linux-gnu/libc.so.6(+0x33060) [0x7fd69c835060]
( 5.975s) [paraview ] :0 FATL| Signal: SIGSEGV

Note again that this error happens upon ParaView exit, after a perfectly normally working session
(but it is a pain in the case of automated scripts using CataLyst for example, where a working simulation reports an error, complicating our error handling with false positives).

I have not yet build ParaView 5.9 on this machine (but built it using OSMesa on our latest cluster, using RHEL8, and do not recall having the same error on initial tests, but will soon have more user feedback). I’ll check with colleagues who have newer Debian 10-based laptops to see if they have similar issues.

Hi,
I am having a similar problem and the --mesa command gives the same error. When I do the glxinfo command I get the following:
Vendor: Mesa/X.org (0xffffffff)
I downloaded Paraview 5.9.1 as a tar file and extracted it so I don’t know how to do the cmake commands later in this thread. Does anyone know how to get this to work?
Thank you,
Jake