Visualizing multiblock dataset only shows single processor block

I apologize if this is an elementary question. I’m attempting to visualize a multiblock dataset using the tecplot reader. When I open the file and hit apply, only the first block is shown. Am I missing a setting to have all datablocks appear? I upgraded from 5.2 to 5.8 and it used to automatically show all the blocks when I hit apply. My professor installed the original version so I’m not sure if there’s a setting I’m missing in my upgraded version. Any help is greatly appreciated!

There is nothing specific to do to read all the blocks. See this file as an example :
3dgeom.dat (966 Bytes)

@mwestphal I opened your file and I saw two parallel plates for the 0 and 1 blocks. Were there supposed to be more blocks? When I open my group of tec files, it seems it’s only opening the first one in the sequence and only displays a single block. I assume there is a simple setting I’m missing somewhere.

Please share a file that shows the issue.

Here’s the first time step. When I load it, it only shows the first block of the mesh.

Well, when you open the file, there is an error that says :

    ERROR: In /home/buildslave/dashboards/buildbot/paraview-pvbinsdash-linux-shared-
release_superbuild/build/superbuild/paraview/src/VTK/IO/Geometry/vtkTecplotReader.cxx, line 2179
    vtkTecplotReader (0x5b256d0): /home/glow/Downloads/M-0001.tec: 
The record type X found in the file is unknown.

So I think either your file is faulty or there is a bug/missing feature in our reader.
That being said, I take a quick look at the file and did not see multiple blocks inside.

To have some insight on this, can you open your file with another software to check it does contains multiple blocks and if X is read correctly ?