Volume Rendering in ParaView Tutorial

I am going through the exercises in the ParaView Tutorial-5.8.0 document and am currently attempting Exercise 2.16 (Turning on Volume Rendering) in Section 2.10 of the document. I open the file disk_out_ref.ex2 and change the variable viewed to Temp and the representation to Volume. However, when I do that, the view window just goes black. I can still see the Temp legend and the coordinate axes, but everything else is black. I believe I am supposed to see the translucent volume, as shown in the Tutorial document for this exercise. Has anyone else reported having a similar issue like this and are there any suggestions for what I am doing wrong? Thanks so much.

Hi Scott, welcome to ParaView!

On what kind of computer and graphics hardware are you running ParaView? It is possible your system doesn’t support the default volume renderer for disk_out_ref.ex2.

As a potential workaround, try changing the Select Mapper property in the Properties Panel to “Resample to Image” and see if volume rendering works.

Hi Cory,

Thanks very much for the assistance. I am using a 2017 MacBook Air laptop using an Intel HD Graphics 6000 1536 MB graphics card. The computer is relatively new, so I would expect its equipped with a strong graphics card, but I could be wrong.

I tried your suggestion of changing the Select Mapper property to “Resample to Image” and that worked initially, in that I can immediately see the translucent volume as shown in the tutorial doc. However, when I try to do subsequent processing, such as adding a stream tracer as called for in Exercise 2.17, Paraview unexpectedly crashes on me. Even if I just toggle the Select Mapper property from “Resample to Image” back to “Projected Tetra”, it might work the first time, but it eventually crashes as well if I keep toggling back and forth. When I then re-open Paraview, sometimes a “Problem Report for Paraview” dialog box opens up showing some details about the crash. It appears from looking briefly at the details that a segmentation fault occurred. I am not sure if this is due to a problem with the system I am running or something within the Paraview code itself.

For now, I think I may need to skip this section of the tutorial doc. If you know of any other workarounds I can try, please let me know! Thanks very much.

Scott

Scott,

When the problem report appears, please click on the button as if you are going to report the issue, but then just copy and paste the text here (we don’t get the error reports). Then you can cancel the report. The text will shed light where the problem is occurring.

Thanks,
Cory

Cory/ Scott,
I suspect this is the “showstopper” bug that I found last January. After we looked further, we decided it was only my MacBook, and I probably needed to update drivers, thus didn’t stop the 5.8 release. As I don’t have control over the drivers, we decided I couldn’t present the volume rendering part of the tutorial. I thought I wrote it up, but I didn’t. Not sure if I should, since it is probably not ParaView…

Hi Cory and Walter,

Thanks for the information on this. I’ve tried to re-produce the issue several times in order to see the problem report again (so that I can copy the details and share it), but the problem report is no longer showing up for some reason, although the crashes are still occurring as I described previously.

Walter, per your comment, does this mean that the issue is due to the fact that the MacBook I am running ParaView on does not contain all of the appropriate drivers needed to support Volume Rendering? If so, do you know if there is any way I can download/install the appropriate drivers to support this functionality?

Thanks so much,
Scott

Cory,

I realized that the reason that the problem reports were not showing up was probably because I had failed to close out of a previous problem report and it the previous one just hidden behind several open windows on my screen. I’ve attached a screenshot of the problem report as a .jpeg image, and also copied the full text of the report into a Rich Text document (RTF) format. There’s a lot of information here, and I’m not quite sure how to interpret it, but hopefully it is helpful. Thanks, Scott

Screenshot of Problem Report:

Text Document of Problem Report
Volume Rendering crash details_5.26.20.rtf (114.9 KB)

I have never seen crashes. I just have the beloved blue-gray background of the 3d view turn to black. Since this was only seen on my old mac, we decided to just ignore it.

@wildecats Based on the problem report, it seems like the volume mapper is crashing on your machine. Is it possible for you to try the latest ParaView nightly? You can download it from https://www.paraview.org/download/ and selecting “nightly” from the dropdown.

Thanks so much for the information! I downloaded the ParaView nightly version and I’m now able to use Volume Rendering without the crashing issue.

I was experiencing the same problem.
The workaround, changing the Select Mapper property to “Resample to Image” works in my case.
I noticed something more that might help the developers, in case they want to resolve the issue.

I have two installations of ParaView Version 5.10.0.
Both are running on the same PC with Windows 10, so the hardware is identical in both installations.
But one installation runs on Ubuntu 20.04 in WSL1 and the other runs as a normal Windows application.

In order to ensure that the same conditions are applied, I perform the command Edit > Reset to Default Settings in both ParaView instances.

Volume Rendering works fine with ParaView in Ubuntu, but nothing is displayed in the ParaView Windows application.

As already said, in the ParaView Windows application, just turning the Select Mapper property to “Resample To Image” make it show a result for Volume Rendering.