VRPN plugin not seen 5.6 version from sources


(Joni-Pekka Kurronen) #1

This is old way , https://www.paraview.org/Wiki/Immersive_ParaView so added PARAVIEW_USE_VRPN, … I have got spacemouse from 3dconnexion to work whit paraview.
Is there big change done at software that I have not noted ?

cmake-gui say’s:

===
Plugin: ThickenLayeredCells - Filter to thicken layered cells : Enabled

Plugin: VRPlugin - Virtual Reality Devices and Interactor styles : Disabled

Plugin: VTKmFilters - VTKm many-core filters : Enabled

I do have:
-qt5-default from ubuntu ppa
-vrpm server build git hub sources

Commandline options:

-DVRPN_LIBRARY:PATH="/mpi/C5/vrpn/lib" -DVTKm_ENABLE_OPENMP:BOOL="1" -DVTK_LIBRARYES:PATH="/mpi/C5/VTK-8.2.0/lib" -DVRPN_INCLUDE_DIR:PATH="/mpi/C5/vrpn/include" -DVTK_LIBRARIES:PATH="/mpi/C5/VTK-8.2.0/lib"

Cache file:

VRPN_LIBRARY:PATH=/mpi/C5/vrpn/lib

VTKm_ENABLE_OPENMP:BOOL=1

VTK_LIBRARYES:PATH=/mpi/C5/VTK-8.2.0/lib

VRPN_INCLUDE_DIR:PATH=/mpi/C5/vrpn/include

VTK_LIBRARIES:PATH=/mpi/C5/VTK-8.2.0/lib


(Mathieu Westphal (Kitware)) #2

vrpn is still the way to connect a 3D mouse.


(Joni-Pekka Kurronen) #3

Have you reason why it dose not compile even

all directryes and FLAGS are set ?

Is there change at Cmakefiles ?


(Mathieu Westphal (Kitware)) #4

Which error are you seeing ?


(Joni-Pekka Kurronen) #5

I can not compiled or installed version plugin directory VRPN
plugin.

cmake-gui say’s:


(Mathieu Westphal (Kitware)) #6

Your message seems incomplete.


(Joni-Pekka Kurronen) #7

I can not FIND compiled or installed version plugin directory
whit VRPN plugin.

  So clearly paraview dose not show vrpn plugin at plugin menu

eighter.

cmake-gui say’s while converting :


(Mathieu Westphal (Kitware)) #8

Please copy and paste your error.


(Joni-Pekka Kurronen) #9

Plugin: VRPlugin - Virtual Reality Devices and Interactor styles : Disabled


(Mathieu Westphal (Kitware)) #10

Enable the plugin in cmake ?


(Joni-Pekka Kurronen) #11

Instructions are here https://www.paraview.org/Wiki/Immersive_ParaView


(Mathieu Westphal (Kitware)) #12
  • When configuring cmake enable BUILD_SHARED_LIB, PARAVIEW_BUILD_QT_GUI, PARAVIEW_USE_MPI and PARAVIEW_BUILD_PLUGIN_VRPlugin .

(Joni-Pekka Kurronen) #13

cmake-gui configure removes PARAVIEW_BUILD_PLUGIN_VRPlugin flag away

and say's :
`

`

Plugin: VRPlugin - Virtual Reality Devices and Interactor styles : Disabled

Only warning from configure is non-related:

CMake Deprecation Warning at ThirdParty/IceT/vtkicet/CMakeLists.txt:14 (CMAKE_POLICY):
The OLD behavior for policy CMP0017 will be removed from a future version
of CMake.
The cmake-policies(7) manual explains that the OLD behaviors of all
policies are deprecated and that a policy should be set to OLD only under
specific short-term circumstances. Projects should be ported to the NEW
behavior and not rely on setting a policy to OLD.

``


(Mathieu Westphal (Kitware)) #14

I do not see this bug with ParaView 5.6.0 sources.

in your terminal, do the following:

mkdir build
cd build
cmake -DPARAVIEW_BUILD_PLUGIN_VRPlugin=ON /path/to/paraview/5.6.0/sources/

my result is:

...
-- Plugin: VRPlugin - Virtual Reality Devices and Interactor styles : Enabled
...

(Joni-Pekka Kurronen) #15

OK, it’s looks like if you define FLAG at cmake-gui it dispeares while creating,
IT WORK*S WHIT clean, fresh, diretory and cmake whit all flag’s like:

cmake /mpi/S5/ParaView-v5.6.0
-DCMAKE_INSTALL_PREFIX=/mpi/C5/ParaView-v5.6.0_v2
-DCMAKE_BUILD_TYPE=Release
-DBUILD_SHARED_LIB:BOOL=TRUE
-DPARAVIEW_BUILD_QT_GUI:BOOL=TRUE
-DPARAVIEW_USE_MPI:BOOL=TRUE
-DPARAVIEW_BUILD_PLUGIN_VRPlugin:BOOL=TRUE
-DVRPN_LIBRARY:PATH=/mpi/C5/vrpn/lib
-DVTKm_ENABLE_OPENMP:BOOL=1
-DVTK_LIBRARYES:PATH=/mpi/C5/VTK-8.2.0/lib
-DVRPN_INCLUDE_DIR:PATH=/mpi/C5/vrpn/include
-DVTK_LIBRARIES:PATH=/mpi/C5/VTK-8.2.0/lib


(Joni-Pekka Kurronen) #16

THANK ’ S

joni

ps. you can not just post wors THANK’s to forum, let’s

see if e-mail dellivers those!


(Joni-Pekka Kurronen) #17

cd /mpi/S5/builddir/ParaView-v5.6.0_v2
cmake /mpi/S5/ParaView-v5.6.0
-DCMAKE_INSTALL_PREFIX=/mpi/C5/ParaView-v5.6.0_v2
-DCMAKE_BUILD_TYPE=Release
-DBUILD_SHARED_LIB:BOOL=TRUE
-DPARAVIEW_BUILD_QT_GUI:BOOL=TRUE
-DPARAVIEW_USE_MPI:BOOL=TRUE
-DPARAVIEW_BUILD_PLUGIN_VRPlugin:BOOL=TRUE
-DPARAVIEW_USE_VRPN:BOOL=TRUE
-DVRPN_INCLUDE_DIR:PATH=/mpi/C5/vrpn/include
-DVRPN_LIBRARY:PATH=/mpi/C5/vrpn/lib
-DVTKm_ENABLE_OPENMP:BOOL=1
-DVTK_LIBRARYES:PATH=/mpi/C5/VTK-8.2.0/lib
-DVTK_LIBRARIES:PATH=/mpi/C5/VTK-8.2.0/lib

There was not TYPE selection so I try above, -DPARAVIEW_USE_VRPN:BOOL=TRUE
next,… if it work’s then


(Joni-Pekka Kurronen) #18

This is quite common whit cmake-gui,…

clean directory and cmake solves problems,…

It can be problem at CMAKEFILES.