vtkexodusII issue during compilation Paraview-5.6.3

Hi all,
i am trying to compile OpenFOAM v2012 in my Archlinux machine, i successfully compiled OpenFOAM part, but when compiling Paraview-5.6.3, i am facing the following issue


i tried the same on OpenFOAM v2006 and got same issue… so i think it is something to do with my config… when i checked online, i found similar issue faced by someone with other tool that uses vtk https://discourse.slicer.org/t/build-fails-in-vtkexodus-on-linux/12018

i have attached my log entry during compilation… log.paraviewCompile2 (317.0 KB)
could u plz help me in fixing this?.. thank you in advance

P.S. i searched existing topics in here for the issue, i couldnt find one, so i created a new topic

Can you try building a more recent version of ParaVIew ?

i tried it and it got compiled successfully… but i cant use that because, the OpenFOAM plugins are compatible only with the version of Paraview that it ships with. and that is 5.6.3. I need the same paraview version to work because my workstyle depends on those plugins from OpenFOAM

Even if you build 5.6.3, it would not have been compatible. You either need to use paraFOAM, shipped with OpenFOAM, or build the plugins yourself.

By the way, ParaView already contains a different OpenFOAM reader that can be used directly.

Hi, i compiled OpenFOAM v2012 on OpenSUSE Tumbleweed machine but not the Paraview like before… but this time, it threw a bunch of ‘undefined reference’ errors, the starting of the error is given as below
[ 54%] Building CXX object VTK/Wrapping/Python/CMakeFiles/vtkFiltersGeneralPythonD.dir/vtkWarpLensPython.cxx.o /usr/lib64/gcc/x86_64-suse-linux/10/../../../../x86_64-suse-linux/bin/ld: CMakeFiles/vtkProbeOpenGLVersion.dir/vtkProbeOpenGLVersion.cxx.o: in function 'vtkRenderingOpenGL2_ModuleInit::~vtkRenderingOpenGL2_ModuleInit()': vtkProbeOpenGLVersion.cxx:(.text._ZN30vtkRenderingOpenGL2_ModuleInitD2Ev[_ZN30vtkRenderingOpenGL2_ModuleInitD5Ev]+0x5): undefined reference to 'vtkRenderingOpenGL2_AutoInit_Destruct()'

i tried installing vtk library and compiling, but this time also same error… i tried compiling the VTK version that comes with OpenFOAM, there also a similar error is occuring, as shown below.
[ 89%] Linking CXX shared library ../../lib/libvtkRenderingVolumeOpenGL2-8.2.so /usr/lib64/gcc/x86_64-suse-linux/10/../../../../x86_64-suse-linux/bin/ld: CMakeFiles/vtkProbeOpenGLVersion.dir/vtkProbeOpenGLVersion.cxx.o: in function main': vtkProbeOpenGLVersion.cxx:(.text.startup+0x12): undefined reference to vtkRenderer::New()'

could u plz tell me what am i missing in here?.. thank you