vtkGeometryRepresentationWithFaces Error


I would like to get some help regarding an error while running a *.py script.
A brief summary of what I am trying to accomplish is taking screenshots for a total of 3 renderviews (3 columns). The script is taking a total of 3 screenshots of the 3 renderviews in different positions. However, only the last screenshot (last position) is failing to capture the first render view (located on the first column or the left side of the screen).

The error states the following:

ERROR: In /Users/kitware/dashboards/buildbot-slave/a64f5607/build/superbuild/paraview/src/VTK/Common/ExecutionModel/vtkExecutive.cxx, line 780
vtkPVDataRepresentationPipeline (0x600001d380f0): UpdateInformation invoked during another request.  Returning failure to algorithm vtkGeometryRepresentationWithFaces(0x7fe442700000).

I appreciate any help.

Please share the python code to reproduce.

Here is the attachment.
Full_Test_D.py (129.0 KB)

Thank you.

You seem to have quite identified the issue, can you reduce the size of your python script in order to single out the issue more clearly ?

I honestly have not been able to identify the issue at all.

Here is part of the code where I try to set up my last screenshot that is giving me problems.

Hopefully this works. If it does not help at all, I can try sending you another section where I believe the error may be pointing at.

Thank you.
Error.py (3.4 KB)

What happens if you create a very simple source and three views ? Can you reproduce in that case ?

Yes. I tried that by just setting up the screenshot that did not work.
The attached *.py worked and did not throw any errors.

Working Version.py (12.7 KB)

But I am just wondering why this view is not being captured in the more extensive code version.
Hopefully this works.

Thank you.

I’m afraid this will require more investigation to be able to figure out what is going on.

I understand that.

I am able to use the more extensive code to generate the first two screenshots while the other code provides me with the last screenshot that I am able to replace.

Thank you.