Windows 10 Error when reading uncompressed binary data header from vtu

Hello all,

I am using the current Version ( extracted to my user-folder, since I do not have admin rights on this machine.

From my Code (C on a Linux machine), I am writing an uncompressed binary (.vtu) file as follows:
<DataArray type="Float64" Name="density" NumberOfComponents="1" format="binary"> DATA <\DataArray>

I am able to load the file, read some variables, display them. So everything seems fine.
However, for some variables, I get the following errors:

ERROR: In C:\glr\builds\paraview\paraview-ci\build\superbuild\paraview\src\VTK\IO\XMLParser\vtkXMLDataParser.cxx, line 655
vtkXMLDataParser (0000021940E0D960): Error reading uncompressed binary data header.  Read 0 of 4 bytes.

ERROR: In C:\glr\builds\paraview\paraview-ci\build\superbuild\paraview\src\VTK\IO\XML\vtkXMLDataReader.cxx, line 410
vtkXMLUnstructuredGridReader (0000021942722080): Cannot read point data array "r_viscosity_avg" from PointData in piece 0.  The data array in the element may be too short.

I dug a bit deeper, and it seems, that for this dataset, the first 154 variables are working well, however, all later variables display the error above.

I also tested this case on Linux with the same paraview version, where the error does not occur. So I think that everything should be fine with my data.

Since I can also “unload” the faulty variables, I suspect that it is not a memory problem.

Does anyone have any idea, what the reason for this behavior may be?

Best, Stephan


It looks like there is something wrong with the content of your file for some variables.
Can you share the file so we can check?



unfortunately, the file is quite big (3.4 GB) and containts a geometry, that I am not allowed to share.

However, as I wrote in my first post, the fiels works flawlessly on my Linux (RedHat) Machine.

I will try to reproduce the error with another Geometry, if that may help.


So i just tested a little bit more:

  • I tried it with an older paraview version (4.4.0) on both Linux and Windows and the problem stays the same (works on Linux, fails on Windows).
  • I tried it with another dataset (smaller grid), but could not reproduce the error (The smaller dataset is ~1GB, the big one has 3.4GB)
    • this seems to show that the file structure works well and that there might be a memory problem on windows
  • I tried reordering the variables and it still happens with the variables that I write later, regardless of the variables themselves. (E.g. before, the error occured on var No. 154 (pressure). Later, pressure was var. no 21 and displayed without error, however another variable after No. 153 displays the error then).

For the moment, I will use the pvserver-Option on my Linux-Mashine to view the Files (which also saves time for copying data). But the problem should nontheless be adressed, if it occurs to other Windows-Users as well.

1 Like