Animation is slow on 5.10 but not on 5.8.2

Hello,

I am trying to use the animation scene. The pipeline is pretty basic: one pvd file and a glyph filter (see picture).

Version 5.10.0: When using the snap to time step mode the animation is super slow, with lags when you pull manually the time cursor. Same for the real time mode, when changing the overall duration to a lower 10s the animation is only showing a sequence of 10 images out of 4497 in my case. So it seems that the glyph filter is really slow and Paraview cannot apply this filter fast enough.

Version 5.8.2: The animation is much faster for this version I don’t know why. Really it is night and day. So I guess there is a default parameter somewhere in Paraview that allows maybe Paraview to apply the filter to all timesteps before launching the animation? That’s my own interpretation.

Question: Do you know if there are anything that can be done to make the animation faster on 5.10? I would like to precise that I do only one loop of the animation as it is quite long (real time is 788s).

You can try to use animation cache

Thanks for your quick reply.

The animation cache is on. The thing is that this animation cache is only working once you have already done one loop of visualization if I am not wrong.
You can see the difference in animation speed below:

please share your data.

Here it is:
5474.7z (675.0 KB)

It is fast here (ParaView 5.10.0 binary release, ArchLinux)

Peek 2022-02-25 10-33

So no clues why it is fast on yours but not on mine?
I am on windows

You want to identify what exactly is slow ? Reading time ? Filter execution ? Rendering ?

Use the Tools → TimerLog for that.

It’s not clear what steps are time consuming from the timer log, maybe changing the pvd ID but still 0.03s is fast:
TimerLog.txt (4.3 KB)

The log is missing any reading time from file. Here what I would have expected for a single timestep:

Local Process
RenderView::Update,  0.005497 seconds
    vtkPVView::Update,  0.005263 seconds
        Execute 5474.pvd id: 22357,  0.001401 seconds
        Execute 5474.pvd(UnstructuredGridRepresentation)/SurfaceRepresentation id: 22573,  0.00046 seconds
        Execute 5474.pvd(ExtractSelection:0) id: 22358,  1.2e-05 seconds
        Execute Glyph1 id: 22708,  0.001706 seconds
        Execute Glyph1(GeometryRepresentation)/SurfaceRepresentation id: 22966,  0.000216 seconds
        Execute Glyph1(ExtractSelection:0) id: 22709,  1.1e-05 seconds
PVDReader::GatherInformation,  0.000702 seconds
vtkSMRepresentationProxy::GetRepresentedDataInformation,  0.000561 seconds
PVDReader::GatherInformation,  0.000253 seconds
Glyph::GatherInformation,  0.000487 seconds
vtkSMRepresentationProxy::GetRepresentedDataInformation,  0.000266 seconds
Still Render,  0.001925 seconds
    Render (use_lod: 0), (use_distributed_rendering: 0), (use_ordered_compositing: 0)
    OpenGL Dev Render,  0.000531 seconds
    OpenGL Dev Render,  0.000361 seconds
    OpenGL Dev Render,  1.2e-05 seconds

My bad, the time threshold was active at 0.001s. Here is what I get when I put it on ‘show all’:
TimerLog.txt (6.4 KB)

Then I have no idea what is causing the slowness tbh.

The filter does not seem to be the cause, it is slow even without it…
If I find a fix I’ll let you know

If you want to compress the dataset with something other than 7z, I will take a look. I cannot open a 7z format.

I guess zip format is better:
5474.zip (1.5 MB)

For your info I did the timerlog with the 5.8 version to compare with 5.10. The biggest difference is in the render view update when it executes the next pvd id.
TimerLog5.8 (28.0 KB)

OK, I took a look at this. A few disjoint thoughts

  • I am seeing a slowdown between 5.8 and 5.10. However, it is very small. With 5.8, I’m getting around 14 timesteps per second, on 5.10 I’m getting about 11 timesteps per second. This is on my Macbook. I then tried Linux, and Linux remote server (software rendered). Only the software rendering seemed to lag somewhat, but was still extremely usable.
  • I tested with just play, then drug the Annotate Time time slider. Again, results were extremely similar.
  • Your dataset is a weird one. Time is not consistent. I believe this was not the issue, but it is strange.
  • My speculation is that you are falling out of hardware rendering into software for some reason.
  • Try deleting your configuration files. These tend to “rot”, and if you have been using paraview for years, but haven’t cleared the out, now is a good time. Edit/ Reset to Default Settings.
  • As a diagnostic tool, so we can add numbers to “man, this feels slow”, in the settings/ Renderview/ Advanced at the bottom is a “Show Annotation” checkbox.
  • As another diagnostic tool, look in Help/ About, and look at the rendering between 5.8.0 and 5.10.0. Are they both hardware?

That’s about all I can think of…

Alan

1 Like

Thanks Alan for taking some time for this issue,

  • I tried with some other computers (always on windows) and the same issue was encountered.
  • The reset to default settings was not successful (I already reinstalled Paraview in an attempt to solve this problem).
  • The show annotation checkbox gave me this information:
    Mode: still
    Level of detail: no
    Remote/parallel rendering: no
    Frame rate: 500fps (oscillating between 500 and 1000)
    As a comparison I did the same with 5.8 and the frame rate is constant at 1000fps, no oscillation at all.
  • Looking at the About section, I could not spot any difference between 5.8 and 5.10 (you already have a screenshot of the about section of version 5.10 a few messages above). I then put here 5.8.

Thanks again for your time

How many cores does your Windows machine have?

4 cores exactly!