Applying ParaView state file to a data set with different number of time steps

Hello everyone,

I have made a pvsm state file with one data set which has 20 time steps as you can see in the picture. What I want is to apply this state file to another data set which has 30 time steps (it is the same data just with additional timesteps), but when I try to do that, ParaView does not register this change in time steps and only shows number of steps from the state file. Even though in this time section I can see that in the toolbar the time steps are going (from 0 to 30), in the data and in this time annotation in the View area, the animation stops at time step 20.
I have tried to modify the pvsm state file by deleting several rows connected to EndTime but that did not change anything. I have also tried tomanipulate the code with LockEndTImeOff but it was unsuccessful. Do you have some ideas on where should I search for the problem?

This really is a good idea. I added a feature request to the bug tracker here:

The only thing I can think of is Fiie/ Reload Files.

Hi, thanks!
I tried File/Reload files option, it does not make any difference.
Does it make sense to manually change the code in the pvsm file? Do you think it could be worth to try something like that?

That would be good thing to try. From experience, .pvsm files are confusing.

Alternatively, when you save state, save as a .py file. These are easier to read, and edit.

1 Like

OK, thank you.

@wascott Hi, I’m sorry for returning to this topic again, but I need to see something. I think that the issue here is caused by the ExtractTimeSteps filter in which I specified the time step range. When you have a state without any filters paraview normally reads and adjusts number of time steps accordingly. What I want to see is here, is there a way to ‘unlock’ this time step range in the pvsm state in this ExtractTimeSteps filter, or is there a filter that works similarly like the ExtractTimeSteps but does not have this time step range.

No clue.
Share your data, plus detailed steps for one of us to create the state file.

@wascott Hi again, I’ve prepared everything. I will attach a document with detailed steps and a gdrive link to get the data. The pvsm state is with the data as well so you can use it if you wish.
steps_paraview_for_developers.odt (19.6 KB)

GDRIVE link: Google Drive: Sign-in

I would really appreciate the help, because I’ve been stuck on this for a long time and I can’t locate the issue at all. Thank you.

@mwestphal Would you be able to take a look? I’m not allowed to log into Google Drive from work…

Ive requested access

Hi, I just accepted it, hope it allows you.

ExtractTimeSteps works perfectly on my side, extracting time from 0 to 9 as it is configured to.

However, I fail to see why you are even using ExtractTimeSteps at all.

Yes, but if you try to apply the state to the other dataset in 20_timesteps directory then and look in the ExtracTimeSteps there will be again from 0-9 not 0-19 and if you click on play then you won’t see the other 10 timesteps and this annotation that I have will stop at 10 and the data in the view area will stop as well at 9nth time step. In the toolbar you will see that the steps are going from 0-19 but then if you look at the data and look at the ‘‘humantime’’ it’ll stop at 9.

This is expected, there is not concept of “ExtractAllTimeSteps” in ExtractTimeStep filter. But why do you want to do that, just do not use ExtractTimeStep at all.

Ok I see, well I tried not using it and then I’ve encountered another problem that you solved the other day by switching from vtu to vtp (ParaView state file problem: state file does not show a slice from a dataset - #14 by mwestphal).
But the original problem of not seeing data after the 9th time step when I use another data set was still there and I don’t know why am I not seeing the data after that 9th time step. If it’s not ExtractTImeSteps I don’t know what is it then? I’m puzzled why I don’t see the data in the humantime annotation and in the view but in the toolbar time area you see it going normally from 0-19 .

Already reported by @wascott here: .

Alright. Thank you.

Hi again,
So I’ve managed to solve this problem. What I needed to do is to select all possible datasets and then apply the ProgrammableFilter, and then select all programmable filters and apply AnnotateAttributedata. And when you load new data set with the larger number of time steps it works.
However, new problem happened. When you try and open the original state with 10 time steps, you won’t be able to see the Slice you’ve made.
This is the new state if you want to check it out:
programmable_filter_applied_to_all_annotation_applied_to_all.pvsm (663.0 KB)