CONVERGECFDreader not available for solid simulations

The CONVERGECFDreader option doesn’t appear for simulations with only a solid stream. I also tried forcing paraview to open the .h5 file with CONVERGECFDreader through the command prompt, but I get the error that there is no mesh in the file.

Here’s a link to a sample .h5 file: link

Because CONVERGECFDReader check if your dataset is of a compatible format and thinks that it is not.

int vtkCONVERGECFDReader::CanReadFile(const char* fname)
  if (H5Fis_hdf5(fname) == 0)
    return 0;

  vtkHDF::ScopedH5FHandle fileId = H5Fopen(fname, H5F_ACC_RDONLY, H5P_DEFAULT);
  if (fileId < 0) 
    return 0;

  // Require a /BOUNDARIES group and at least one STREAM_00 group
  if (H5Lexists(fileId, "/BOUNDARIES", H5P_DEFAULT) == 0 || 
    H5Lexists(fileId, "/STREAM_00", H5P_DEFAULT) == 0)
    return 0;

  // Everything succeeded
  return 1;

Thanks for clarifying this Mathieu!

But what can we do regarding this? Because CONVERGE does give you the option just to run solid simulations without any fluid streams. And there are CONVERGE users who run such simulations. Should paraview include a check for STREAM_01 as well?

This looks like a missing feature in the CONVERGECFEReader in ParaView yes. Should not be too hard to fix for a programmer knowing the format.

Mathieu, do you mean this has to be fixed at paraview’s end or it can be fixed while building paraview?

I’m asking cause I’m not really familiar with building paraview. Thanks!

It has to be added (its not really a fix, more of a new feature) in ParaView source code.

See this:

1 Like

Dear Jameil,

Thank you for reporting this issue.

It looks like the CONVERGE CFD reader expects there to be a stream called STREAM_00, though that is not a requirement of CONVERGE CFD. Do you have the ability to modify your CONVERGE CFD case so that your stream id is 0 instead of 1? Alternativly, you can rename the node “STREAM_01” to “STREAM_00” in your result file using tools such as hdfview.

We will fix the reader, but it will take a few month to make it to an official ParaView release.

If you need further assistance finding a work around on your case, please don’t hesitate to reach out to the CONVERGE CFD support team, we will be happy to help.

Best regards,
Alexandre Minot
Convergent Science


This issue is fixed: