"could not open module lib ospray_module_ispc"

When loading paraview.simple, from paraview version 5.8, on windows, with my own python 3.7, I get this error dozens of times.

#osp: INITIALIZATION ERROR --> could not open module lib ospray_module_ispc: The specified module could not be found.

This does not seem to cause runtime issues, the import ‘finishes’ and most of the basic paraview.simple functions are usable but the errors worry me.

I have added

<pv_install>\bin\Lib
<pv_install>\bin\Lib\site-packages
to my
<python_install>\Lib\site-packages\python37.pth

which is what got paraview.simple importing in the first place. I believe this is how to simulate PYTHONPATH on windows (but could be wrong?)

I have also added several things to my PATH.

<pv_install>\bin
<pv_install>\bin\DLLs
<pv_install>\bin\Lib
<pv_install>\bin\Lib\site-packages

<pv_install>\bin\Lib\site-packages\paraview\modules

I included ‘paraview\modules’ because I saw that the ospray.dll is in there but I’m not suuure if that’s helping anything…

I have reviewed this documentation which is where I got the PYTHONPATH and PATH items
https://www.paraview.org/Wiki/ParaView/Python_Scripting#Getting_Started
As well as two threads:


I am specifically using this paraview install: ParaView-5.8.0-Windows-Python3.7-msvc2015-64bit.exe
And Python 3.7.0 (Could I need a different specific version of 3.7.X?)

2 Likes

Hi I’m having the same error, did you find a way to solve this issue ?

Try setting your PATH (or LD_LIBRARY_PATH on Linux and DYLD_LIBRARY_PATH on macOS) to the directory containing the ospray_module_ispc shared library.

For me ospray_module_ispc is located in “C:\Program Files\ParaView 5.8.0-Windows-Python3.7-msvc2015-64bit\bin” so I’ve set both my user and system variables to this path.

But it doesn’t change anything.

@Dave_DeMarle, any ideas?

not yet, I’m looking in to similar items on mac and will try and look into this too

I have a fix in progress over on the OSPRay’s rkcommon project now. It seems that the way ParaView binaries anchor OSPRay’s dynamic library search point to be relative to the ParaView binary makes it impossible for the user to extend the search path via LD_LIBRARY_PATH and the like. See Library::Library in ospray1/rkcommon for the details.

I am hopeful that my change will solve the issue once merged and propagated up to ParaView.

cc: @ben.boeckel

The fix is under review here and will likely appear in ParaView 5.9. With the change, OSPRay’s runtime library resolution will take user defined PATHS into account.

Just want to follow up here

I ran into the same issue with 5.8, ended up here, tried with 5.9 and alas the errors are gone!

1 Like