Crash when exporting animation


I cannot get ParaView to export a simple animation on on Windows 10 Home, ParaView v5.9.0-RC1. The steps to reproduce my problem:

  • Imported the ParaView example can.ex2 that is provided with the software:
  • Applied a temporal interpolator filter
  • Set the animation time to 15 seconds ‘Real Time’
  • File > Save Animation > Save as AVI > OK

The program crashes every time. Any ideas how to troubleshoot this?

Unable to reproduce with ParaView 5.9.1 on Linux.

Thanks. It also crashes when I don’t apply the filter. So just a straight export of the example with real time 10 seconds as AVI. Is there a crash log saved somewhere?

run paraview with the -l option to have a log

Thanks, I added “-l” to the shortcut and ran ParaView. A window briefly pops up but it is way too fast to read. I screenshotted it at least:

The program itself doesn’t load after this. I tried to search the program directory for new files but couldn’t find an error log.

paraview --log=C:\log.out

alternatively you can run paraview from an actual terminal, like git bash.

Thanks, I got the log:
log.out (6.1 KB)

( 16.029s) [paraview ]vtkDemandDrivenPipeline:760 ERR| vtkPVDataRepresentationPipeline (0000015F809D70A0): Input for connection index 0 on input port index 0 for algorithm vtkImageSliceRepresentation(0000015F8186C170) is of type vtkRectilinearGrid, but a vtkImageData is required.

Here is the error. Are you using the SliceRepresentation ?

Sorry, I uploaded the log from a different file (which also crashed when exporting the animation). This was the error file from the can.ex2 example:
log.out (4.2 KB)

The last message is related to the changing of the resolution.

I tried manually setting the resolution in the export to match that in that last error message, and now the log is just missing that line and ends with VisRTXBackend.cxx:42 WARN| VisRTX Error: Unsupported device.

log.out (4.0 KB)

This warning is just a warning and is not related to your issue.

I was not able to reproduce your issue on Microsoft Windows 10, using ParaView 5.9.0.

1 Like

I will try on another computer as soon as I get a chance. There’s nothing in the crash log then for this one as far as I can tell, so nothing to troubleshoot?


Hi everybody,

I’m having animation crashes as well.
To make things as simple as possible, I tried to follow the animation tutorial (starting from ctrl-space + Sphere) and then saving the animation.
If I choose “PNG” in the “files of type”, everything works well. However, when I choose “VFW AVI files (*.avi)” it crashes with any image resolution, background color and quality.
I also tried the “Ogg-Theora video file” and it works (producing the ogg file) but Windows does not seem to be able to read it.
I tried to delete the .ini file too (as suggested in another thread) but this was not helpful.
I attach the state file, ini file and also the trace file that I got by starting paraview with --log=c:\data\log.txt --verbosity=-2

Thanks very much for your help!
log.txt (4.9 KB)
ParaView5.9.0.ini (12.0 KB)
sphere.pvsm (173.4 KB)

This seems to impact multiple users.

I tried on Windows with ParaView 5.9.1. Can.exo. I was writing .avi’s. Tried default animation view, then realtime, then realtime, advanced save animation, changed time and frame rate. All were fine. I wonder if it is a newer version of Windows? I’m on Windows 10 version 1909.

Thanks, @wascott I’m on version 2004 which was the version after the one you are using. Interestingly, depsite the constant interruptions about updates, my OS is not the 21H1 version. I have started the download for that and will update then let you know if the issue persists.

I have another internal report for this issue from a user.

I’m not able to reproduce on my windows though.

My windows version is 10.0.18363, even older.

OK, one more thing I can think of. Please do a screen capture of Help/ About. Be sure to expand the dialog to show everything. Post that here.

Tested on 20H2, personal Dell Inspiron laptop. All is well.