Difficulty with Stream Lines Representation plugin

Hi All -

I am trying to apply the streamlines representation plugin to streamlines and having some trouble getting the animation applied to the data within the case.

Google Photos

Please let me know if I can provide additional settings.



Nick, welcome to the ParaView community.

I’m not sure I understand the problem you are seeing. Could you say what you expect to see?


Hey Cory, thanks for the welcome. I am hoping to animate the streamlines within the simulation (in the image, the blue particle particle streams in the room). Does this make more sense?

You have three possibilities here :

  1. With streamlines filter, since this filter is not really adapted to animation, you can only use a simple work around to animate the streamlines. See here : https://www.paraview.org/Wiki/Advanced_Tips_and_Tricks#Animating_a_static_vector_field

  2. You can use the “Streamlines representation” plugin very easily. See here :

  3. You could use the more complex workflow of using the particle tracer, but it requires your data to have timesteps within, it does not seems to be the case.

Hey Mathieu, I am trying to use the steam lines animation plugin (option #2 in your advice) but am having trouble applying the animated lines to the actual streamlines in the simulation. Instead (as in the image posted) they float outside of the model. Does this make sense?

You are not supposed to apply the animated lines to the streamlines in the simulation.

Please add a screenshot.

This is the model, the model is a room and the blue lines are particle streams representing airflow through the HVAC and into the interior space. It is a sealed room so the airflow recirculates indefinitely. I am trying to represent this closed loop of airflow. There are different time steps but I am more interested in trying to animate this single state- to give motion to these particle streams in hope they will show how the air looping through the system.

  • Load the Streamlines representation plugin
  • Hide the streamtracer output.
  • Click on the foam reader
  • Open a new view
  • Show the foam reader in the new view
  • Switch to “Streamlines Representation”

When you say “open a new view” is that a new “layout” tab?

That works.

And where am I able to switch to streamlines representation?


Thanks, got it. The way I am able to configure the settings so far, the particle traces generate from their source, trace their path and then dissapear. To show the perpetual looping of the whole system is there a way to show motion within a fixed moment in time? IE in the earlier screen shot, apply an animation to the blue streamlines so that have dashes that move along their paths in the direction of their flow? Does this make sense?

That would be solution 1.

Hello ParaView community,

My first post on the ParaView discourse group.

The answers so far from @mwestphal are very helpful.
I was able to make it run for the simpleFoam Motorcycle tutorial case.
It behaves perfectly and as expected.

I tried using the same filter for an interFoam case (multiphase), but the streamlines are all over the place and make no sense. (It is a water jet inside a nozzle surrounded by air).

They do work though. (Which I had issues for a while).

What might the issue here?
Does it only work for data that is usually available from single phase solvers?
or is it something else entirely.

Thank you. :slight_smile:

Please open your own topic.