How to apply texture to surface with TCoords?

I have a legacy VTK file that has a vtkPolyData stored in it. The surface has texture coordinates. I was trying to load the texture asset, like it says in the documentation), but there is no option in Paraview 5.11.0 to do this?

Plz help …

This wiki seems vey much out of date. here is how to do it:

Wow, a movie, neat.

Ok, it appears that for this particular object, that option isn’t available. I have a legacy VTK file that loads correctly and shows up as “Polygonal Mesh.” There are data arrays recognized as well (normals and tcoords). I can get the normal vectors to show up with a Glyph filter, and they look correct. The texture coordinates (magnitude) show up as a coloring option and look … well … like they are texture coordinates.

Is the “Texturing” option only available for vtkSource, but not necessarily for vtkPolyData?

It should be available, please share your data.

Ok - I’m using Paraview 5.11.0, downloaded … like a week or so ago.

Well, here is another file I could send that has the same problems for me: the Utah teapot. I loaded it in, filtered it with TextureMaptoSphere. It does indeed generate texture coordinates … but when I go to apply a texture, like in your movie, I don’t have those options available.

For “Properties (TextureMaptoSphere1)” I get (only):
Prevent Seam.

If I use “my” data (which is too big to send), I don’t have any properties available at all.

If I reset the session and add a new plane source like you did in the movie, after I click “Apply” … the only properties that I have available are:

  • Origin
  • Point1
  • Point2
  • X Resolution
  • Y Resolution

Well, the teapot is not a sphere. That being said, the option should still be available even if the rendering may not be as expected:

Am I just using the wrong version of Paraview or something? Because your lighting section has a lot more options than mine does.

@mwestphal, I even tried to reproduce your plane example - I never get a set of controls like you show that allows me to pick a texture. Is there something special I have to select to get that?

Can anyone help me out with a download link to the version that @mwestphal is using in his videos? I downloaded 5.11.0, as shown in my screenshot - and none of the texture options are available to me. His lighting section starts off with interpolation, mine starts off with specular. It appears that he is using a different version than that which is available for download at this time?

Seems like it would be simple to just tell me what version was used?

Hi Rexthor,
There are two Properties tabs. One is the default, basic, the other is advanced. Mathieu forgot to mention that he is using an advanced tab while you are using a basic tab. We are hiding the overwhelming amount of controls by default, but still make them available if needed in the advanced tab.

To the right of the search box at the top of the Properties tab, there is a gear icon. Click that. You now have an advanced Properites tab.


1 Like

You guys saved me a bunch of extra coding.

Thanks @wascott , for some reason it did not cross my mind.

For reference: