How to create streamlines animation as the NVIDIA Omniverse demo video

Hi, I recently saw a video which ParaView works with NVIDIA Omniverse and looks really great:
https://www.youtube.com/watch?v=gTiqV3akBIE
I’m interested in streamlines animation from 1:19 to 1:38 and have two questions:

  1. I remember ParaView doesn’t support exporting streamlines animation as video, but seems it could be done by using NVIDIA Omniverse?

  2. How to achieve this evenly spaced like streamlines animation? It’s done by using StreamLines or StreamTracer with some tricks to make it animated?

Thanks in advance.

Not true. You can export animation containing streamlines, eg: StreamTracer or ParticleTracer output.

You cannot export “StreamlineRepresentation” output as an animation if that is what you are reffering to, but this is within a plugin, not in default ParaView.

How to achieve this evenly spaced like streamlines animation? It’s done by using StreamLines or StreamTracer with some tricks to make it animated?

Evenly Spaced Streamline 2D I suppose.

Hi Mathieu,

Thank you for the reply.

I’m reffering to StreamlineRepresentation.
I think I’ll try using NVIDIA Omniverse then, hope it will do the exporting job.

Just tried using Evenly Spaced Streamline 2D and StreamTracerWithCustomSource, with latter one I can get image which is really close to the video:


Wondering is there a way that I can make it animated like StreamlineRepresentation? (since StreamlineRepresentation cannot control lines’/seed points’ distribution)

You need to use contour and glyphs with an animation as explained here:

Thanks Mathieu.

Mathieu, thank you so much for the turoial video, especially the last part.
Now I’m able to make a video pretty similar to the video I mentioned above:


But the particle path only disappears when it goes outside the dataset, and I also used “Force Reinjection every NSteps”, the video become messier with time.

Then I found ParticlePath has a property called “Termination Time” which I thought will be the solution(ParticleTracer and TemporalParticlesToPathlines don’t have property like this). But whenever I choose ParticlePath filter, select the input/seed source and hit apply, my timesteps become 0, making it unable to animate. Did I use it wrong? Thank you.

TerminationTime or MaximimNumberOfSteps should work.

Are these properties or filters? Can’t find anywhere.

Maximum Steps is a property of the EvenlySpacedStreamlines2D

I used:

  1. Mask Points
  2. ParticleTracer
  3. TemporalParticlesToPathlines

to make the animation I uploaded above, and EvenlySpacedStreamlines2D seems unable to do so.

For easier understand, here are my state file and data:

My goal is 1:29~1:38 in this video:

ParticleTracer has these options.

Not seeing TerminationTime nor MaximimNumberOfSteps in ParticleTracer.

There’s Termination Time in ParticlePath, but that’s the filter I got problem with. Thank you in advance as always.