How to scale data and keep axis correct?

I’m a newbie to paraview. I have some points I’ve managed to plot with a ScatterPlot from a csv file. As you can see the values vary much less on the Z-axis than the others, but I’d like to still see the variation. There seems to be no way to scale the data along the Z-axis so that the Z-axis labels also scale with the points and they’re in the right place.

So as of now, the data lies in the range [0.2, 0.7]. I don’t want that to change, I want the whole Z-axis and the data to be scaled up. When using scale under Properties, the data is scaled but the axis doesn’t move so now all the points are incorrectly placed. Same with the calculator.

Forgive me, this seems like it should be easy but every single thread asking this question has no replies and is dead. I don’t know what else to do.

Thank you.

Update: I found exactly what I’m looking for in ParaView 4.4.0, with cube axes. I can scale up along an axis under the Transforming options, then under the Cube Axes Properties check ‘Original Bounds as Range’ for the axis I scaled. Why isn’t this possible anymore; is there any way I can do this in 5.8.0?

With ParaView 5.8.0, you should be able to get what you want by doing the following.

  1. Add the Transform filter to your data. Change the Scale for the Z axis to whatever you want. Apply.
    • At this point you will see that the axes grid (the axes labels on the bounds) are wrong for your data because they show the rescaled size. We’ll fix that next.
  2. Click on the Edit button next to the Axes Grid property in the Properties panel to open up the edit dialog box for the grid.
  3. In the axes grid editing dialog box, find the Data Transform controls. Change the Data Scale to match what you used for the Transform filter. Click Apply or OK and now the axes grid should match the actual scale of the data.
2 Likes