Incomplete paraview installation, missing catalystd.dll

Since last two weeks I am trying to build Paraview 5.12 from source code with catalyst enabled for purpose of in-situ visualization. Before my laptop breakdown after numerous configurations, and builds I thought of seeking the help of experts.
Part 1.
I followed the instructions given on build page for building and installing paraview 5.12 that requires Qt5.15.3 and other prerequisites. I followed the steps outlined at for Qt5 installation from source code. While configuring Qt5 I used -platform win32-msvc option for using Visual studio as compilation tool.
Post installation of Qt5 I could not follow the below steps for paraview:
- Make sure to add C:\Qt\Qt5.15.3\5.15.3\msvc2019_64\bin to your PATH environment variable.
- You may also need to add an environment variable QT_QPA_PLATFORM_PLUGIN_PATH: C:\Qt\Qt5.15.3\5.15.3\msvc2019_64\plugins\platforms.
The reason was missing MSVC2019 directory at location “C:\Qt\Qt5.15.3\5.15.3” . I searched on internet how to get this directory while building Qt5 from source code but I could not come across any help on the subject. Thought that the problem could be with the particular version of Qt. Which made me switch to Qt 5.15.13 (the latest release of Qt5) but this too failed with same reasons. Not to mention that the Qt as a standalone application worked fine in both the cases.

Skipping over this, after building the Paraview when I try to launch it I am bombarded with errrors like no QtWidgets.dll … and other missing dlls related to Qt5, and missing dlls of catalyst.

Part 2.

  1. Swaying away from the instructed version of Qt 5.15.3 I went with qt-opensource-windows-x86-5.12.12.exe hoping that the GUI version will give me an option to tick MSVC2019 as mentioned in line “Download and install Qt 5.15.3 for Windows, make sure to check the MSVC 2019 64-bit component during installation”. The exe offered such an option but not for MSVC2019 rather MSVC2015 and MSVC2017, I selected latter one and finished the installation.

  2. For paraview installation I used “x64 Native Tool command prompt for MSVC2017” rather than “… MSVC2019” coz I have corresponding MSVC2017 directory in Qt. Since I have no understanding of whats going on under the hood I assumed that during Qt installation I ticked MSVC2017 for cmake so I should use cmake.exe from “x64 Native Tool command prompt for MSVC2017” for paraview installation.

  3. Before configuring paraview I added -Dcatalyst_DIR=“C:\ProgramFiles(x86)\CATALYST” to my environment variables. I even checked the output of this variable by echoing its value in the same command prompt as well by printing the value of ${catalyst_dir_primary} inside of foreach loop beginning at line no. 779 of CMakelists.txt using message command.

  4. For paraview configuration I used this particular command “C:\pv\pvb> cmake.exe -GNinja -DPARAVIEW_ENABLE_CATALYST=ON -DPARAVIEW_USE_PYTHON=ON -DPARAVIEW_USE_MPI=ON -DVTK_SMP_IMPLEMENTATION_TYPE=STDThread -DCMAKE_BUILD_TYPE=Release …\pv”. C:\pv\pv contained the source code cloned from the github.

  5. Build was done using same x64 Native Tool command prompt for MSVC2017

  6. Post build when I launch paraview.exe I receive message missing catalystd.dll, which I got rid of by pasting the catalystd.dll from Catalyst installed directory to C:\pv\pvb\bin (paraview’s bin directory)

With same “x64 Native Tool command prompt for MSVC2017” if I try to run the CxxFullExample I get the following message:
Failed to initialize Catalyst: 3
Failed to execute Catalyst: 1
Failed to execute Catalyst: 1
Failed to execute Catalyst: 1
Failed to execute Catalyst: 1
Failed to execute Catalyst: 1
Failed to execute Catalyst: 1
Failed to execute Catalyst: 1
Failed to execute Catalyst: 1
Failed to execute Catalyst: 1
Failed to execute Catalyst: 1
Failed to finalize Catalyst: 1

As instructed on the page setting CATALYST_IMPLEMENTATION_NAME=paraview was done without any problem. But I could not set the CATALYST_IMPLEMENTATION_PATHS=“C:\pv\pvb\lib\catalyst” because of missing catalyst directory in the parent "C:\pv\pvb\lib". Instead of leaving it I set the CATALYST_IMPLEMENTATION_PATHS="C:\pv\pvb\lib".

I even tried to rebuild the paraview by changing the value of -Dcatalyst_DIR=“C:\ProgramFiles(x86)\CATALYST\lib\cmake\catalyst2.0” at step 3 but it also added no catalyst directory under /lib/.
If useful one may go through the attached Paraview configuration output and layout of C:\pv\pvb (paraview build directory).
paraviewConfigurationOutput.txt (20.6 KB)
failedParaviewInstallation.txt (261.0 KB)

This is first time I am installing softwares from source code on windows. Please excuse me for my silly mistake.