OPENGL not supported in WINDOWS 10 and Intel HD graphics card, GLEW could not be intialized missing GL version

I can’t open Paraview on a Windows 10 64 bit machine. I get the error:

GLEW could not be intialized missing GL version

By doing some research on google I have found that the latest Intel drivers for Windows 10 for Intel HD 3000 graphics adapters do not support OpenGl which seem totally necessary for ParaView. In this YouTube video and the associated GitHub channel a solution is provided:

It consists of installing the Windows 10 Deployment Kit ( and using the tool “Compatility Administrator” to patch the OpenGL DLLs of the affected program with the fix “Windows81RTMVersionLie”. But I do not know what are the related libraries in ParaView. I have tried with those with “GL” in their name but without success, and since there is a lot of DLLs and you can only select one by one I would appreciate if someone could point me to corrrect ones.

NOTE: There is also the option of installing Mesa drivers with MINGW but this did not work also.

Intel HD 3000 is not supported on windows 10.

I would recommend to either change your GPU or change to another OS that support your hardware. Ubuntu comes to mind.

To use mesa on windows, well you will need to be able to build mesa on windows and then build ParaView with this mesa. I do not recommend it.


You can use mesa3d to provide a newer OpenGL version. This allows computers with Intel graphic chipset or old NVIDIA graphic cards to use applications requiring OpenGL 3.

This workaround works with Salome Platform (which includes Paraview), so it should work for Paraview too.

  • Download Mesa3d for Windows:

  • Extract it (either with double-click or right-click 7-zip)

  • In the extraction folder of Mesa, go to x64, select and copy opengl32.dll

  • In the extraction folder of Paraview, go to the bin folder and paste opengl32.dll

  • Double-click on paraview.exe

Now Paraview should open without error.




Awesome @cbourcier !

@Sirius_Fuenmayor : Please let us know if this works for you.

I know it´s an old topic, but I have same cpu (Intel HD 3000 + amd 6630m as gpu) and the solution proposed by @Sirius_Fuenmayor did not work for me. Intel HD 3000 is not supported on windows 10, but somehow I can run old versions of paraview on my notebok without any problems. Below is a version that still works:

What do you mean that the solution does not work ? Provide errors or describe what is happening.

There is no other way to run a recent ParaView on your environment.

I meant Mesa3d drivers for windows did not work on my machine. Unfortunatelly this is what I get using or not using the procedures discribed by @cbourcier:


I can´t run recent versions of Paraview on my machine, but older versions (below 5.2.0) still working and when I go to help menu, it seams to be using my GPU drivers as in the picture bellow:


Newer versions (above 5.2.0) always crashes on my notebook. Nowadays I am running windows 10 64bits, my gpu is amd 6630m and cpu is i5-2410m wich relies on hd 3000 drivers.

For some reasons the mesa driver is not being picked up by ParaView. You will need to figure this one out as I can’t reproduce.

Hi @lucsanjo,

did you set the GL_VERSION, like mentioned in the step by step instructions:

  • copy x64/OpenGL32.dll and x64/libglapi.dll to ParaView_Path/bin/
  • open a Windows terminal
  • cd ParaView_Path/bin/
  • paraview.exe


1 Like

Hi @cbourcier, thanks for your help!

Yes I did. I’ve tried mesa3d-20.0.6-release-msvc and mesa3d-20.1.8-release-msvc, but I got same erros with both.

Well, it should work with the mesa driver. I have just tried again with 20.1.8-release-msvc and Paraview 5.8.1.
Did you try to force the use of Intel chipset for Paraview instead of the Radeon card?


1 Like

Hi @cbourcier!
Yes I tried to force and unfortunatly it dit not work also.

@mwestphal I found a way to make any versions of Paraview to work in Windows 10 using my machine.

I notice that my problem was happening because Qt was set to use Angle instead of native Opengl provided by hardware ( So the only thing I had to do was to set the variable QT_OPENGL=desktop and it worked.


1 Like

I am also facing same issue. Can you please mention the procedure to rectify that issue? Thanks in advance.