ParaView 5.6.1 on SLES 11 - Possible?

Hi all,

I have a SLES 11 machine and was requested to “install” ParaView 5.6.1 on it. The binary version is not running giving me:

/lib/paraview: error while loading shared libraries: libOpenGL.so.0: cannot open shared object file: No such file or directory

Same problem here but with no fix: getting-libglx-so-0-not-found-error-with-binary-release-of-5-6-1

Does anyone know if is possible to make 5.6.1 work on SLES 11 and how to do it?

Thank you.

Afaik, SLES 11 do not provide a libOpenGL.so.0, you can use ParaView 5.5.0 though.

@ben.boeckel @cory.quammen : Should we worry about that ? Old distribution can’t run 5.6 because they miss libglvnd.

Yeah, I suspect that SLES 11 has fallen off of the platforms supported when we bumped to CentOS 6 (from 2010, one year newer than SLES 11) due to insufficient compiler support available in CentOS 5. It is likely that SLES 11 deployments will need to compile the binaries on such a machine rather than use pre-built binaries.

So, I went with compiling the src on SLES11, using cmake to sort all dependencies, everything went fine, make install… all good, but when executed *build_path/bin/*paraview … I’ve got:

This application failed to start because it could not find or load the Qt platform plugin "xcb"
in “”.

Reinstalling the application may fix this problem.
Aborted (core dumped)

clearly based on the message the path to load the plugin is empty.

This issue I solved with: export QT_QPA_PLATFORM_PLUGIN_PATH=path/to/plugins

Now my error is:

QXcbConnection: Failed to initialize XRandr
/bin/paraview: symbol lookup error: /Qt5.6.3/5.6.3/gcc_64/plugins/platforms/…/…/lib/libQt5XcbQpa.so.5: undefined symbol: XIQueryVersion

So I

export LD_LIBRARY_PATH=/Qt5.6.3/5.6.3/gcc_64/lib

But still getting the:

paraview: symbol lookup error: /Qt5.6.3/5.6.3/gcc_64/lib/libQt5XcbQpa.so.5: undefined symbol: XIQueryVersion

The problem is related to QT and old distros like SLES11

which can be sorted with:

export QT_XCB_NO_XI2=true

Problem Solved… for Now I have ParaView 5.6.1 at least launching on SLES 11 and QT 5.6.3 :slight_smile:

Great ! Could you put all the env variable you had to set in a single post for other users ? Thanks.

1 Like

I will… just have to make sure everything is working.

I have this error https://stackoverflow.com/questions/19534051/glibc-detect-smallbin-linked-list-corrupted when doing the following