Paraview 5.7.0 does not load more than 12000 cells-(ubuntu 20.04 python 3.8.2)

Hi I created an R script to create an KML ASCII UNSTRUCTURED_GRID. It works fine, but when I create a file using the same scritpt with more cells I get the following error:

ERROR: In /build/paraview-vlxewD/paraview-5.7.0/VTK/IO/XML/vtkXMLUnstructuredDataReader.cxx, 
line 601 vtkXMLUnstructuredGridReader (0x558f36e3bbf0): Cannot read cell offsets 
from Cells in piece 0 because the "offsets" array is not long enough.

Tried do to the same using Legacy ASCII and the same thing occurs. Works fine but if I increase the number of cells above ~ 12000 I get this error:

ERROR: In /build/paraview-vlxewD/paraview-5.7.0/VTK/IO/Legacy/vtkDataReader.cxx, line 3276 
vtkUnstructuredGridReader (0x558f3863f3b0): Error reading ascii cell data! for file: 

Two days checking everything, rewrote the script and the same. Is this a bug? files are less than 0.5G. Tried modifying types (float, double) and nothing…


This code changed quite a bit, could you try with ParaView 5.8.0 ?

I will give a try but the Ubuntu 20.04 ‘f… all fossa’ does not come with python3,7, I will install it from source and then i will install 5.8 from source too. Python VTK wheel for python 3.8 is not available for focal fossa yet.

Definitively it is something related to memory handling of ASCII legacy, when I try to open other vtk’s together with the one that opened before (less than 12000 cells). depending on the order it does not open giving the same error. If I open it alone it works. weird.

Thanks anyway, Have a good week!

Ubuntu/Debian provided ParaView 5.7.0 has multiple known bugs. Please use our binary release instead :

Thanks Mathieu, Same problem with 5.8, I will check again my script to see what am I doing wrong, or maybe it is another python 3.8.2 on Ubuntu 20.04 issue