ParaView 5.9 and minimum/recommended QT version

With Qt 5.15 LTS being out since May, it’s probably time to update the QT versions required by ParaView as follows:

  • minimum Qt version: 5.12 LTS
  • recommended Qt version: 5.15 LTS
  • binaries to be built with Qt version 5.15 LTS

Any objections/concerns? If not, we should plan to do this in time for upcoming 5.9 release.

4 Likes

+1

What Qt version do the various distros package by default?

It feels like rendering is faster with Qt 5.15. Did not measured that though.

Ubuntu 16.04 (EOL 2021) : Qt 5.5
Ubuntu 18.04 (EOL 2023) : Qt 5.9
Ubuntu 20.04 (EOL 2025) : Qt 5.12

Debian Stretch (EOL 2020) : Qt 5.7
Debian Buster (EOL 2022) : Qt 5.11
Debian Bullseye (NO EOL) : Qt 5.14

Centos 6 (EOL 2017) : Qt 5.6
Centos 7 (EOL 2020) : Qt 5.9
Centos 8 (EOL 2023) : Qt 5.12

Fedora 30 (EOL 2020) : Qt 5.12
Fedora 31 (EOL 2021?) : Qt 5.12
Fedora 32 (EOL 2022?) : Qt 5.13

OpenSUSE 15.1 (EOL 2020) : Qt 5.9
OpenSUSE 15.2 (EOL 2021) : Qt 5.12

from pkgs.org

Unless we get a champion to chaperon this change, this may not happen for 5.9.

ParaView 5.7 builds and works fine using Qt 5.15.1 with a number of deprecation warnings on macOS

Update: ParaView 5.9 will require Qt 5.12. Please see https://gitlab.kitware.com/paraview/paraview/-/merge_requests/4422/diffs?commit_id=24fcce7e8027f48f22dee2396eb828491934838c.

And I noticed that visual studio versions required by paraview has changed to 2017(all previous versions of paraview requires VS-2015). Looks like a big update.