Paraview for macOS Monterey

Is Paraview available for macOS Monterey?

1 Like

I believe the upcoming ParaView release 5.10 is compatible, you can try the RC1 release:

Thanks. I have downloaded release 5.10 RC1 but when I try to install I get the message:
“There are no mountable file systems in the disk image” .


Did the disk image ultimately mount despite the message? That was our experience when testing.

No it did not mount.

A mac os monterey user here. Would love to know if the new RC2 release has been tested with monterey os. Just installed it and looks like the application just hangs after opening. I cannot toggle any options or load any file. Any solution to my problem is greatly appreicated. I have had to make dew with running the application on my windows till now but would love to know if the new mac os supports paraview.

Not sure if this is even related but sounds like a bug we hit with our application on Big Sur. Try “export QT_MAC_WANTS_LAYER=1” on a command line and then try opening ParaView through that same terminal. Google for “QT_MAC_WANTS_LAYER” for others that have a similar sounding issue. Maybe this is related, maybe not…

Thanks for the suggestion. Beause of your reply I finally decided to dig deep on my own and tried a few things including your suggestion. Ultimately a simple thing suggested by the person Walter Scott in an earlier blog related to Big Sur helped in getting the new release to work on my mac.

I can confirm this.
It would be great to have a proper Monterey build

The weird part is that if we just build our Qt based application it will run normally on Big Sur and Monterey. It is when we package with Anaconda that we have the problem. Anaconda does use Qt 5.12 where as I think we build the stand alone with Qt 5.14 (if I remember correctly). Not sure what Qt version ParaView is using for their release builds.

I have used Paraview with my old Mac and Big Sur and I was very happy with it.
Now I have a new Mac with Monterey and I still have the problem that I get the error message “no mountable files” when I try to download. There are 8 files to choose from for 5.10 release and I took the first one. Correct?
Hope I can use Paraview on my new computer soon.
Thanks for your efforts.

I am not a mac os expert since I am very new to mac. But I did manage to get Paraview 5.10 RC2 release working on my mac. To be honest all the installation files with .dmg extension gave me the same error as what you experienced. So try downloading the ones with .pkg extension which I believe are kind of zip file installation. Specifically for me the last file with (.pkg extension) worked.
However, you will run into app freezing issues when you start up your paraview every time. In order to solve that refer to an earlier post on freezing issues or the link I posted in my last message. The only inconvenience is that you will experience the screen freeze everytime you boot up the app. Thats how I got the new release of parview working on my mac. If anyone has any better solutions it would be greatly appreciated.

Thanks. I successfully downloaded Paraview but I still have the freezing issue. I am not sure about the solution you propose. If it involves moving the /.config files I can not find them.

The config folder I think is hidden. As soon as you open terminal if you do cd ./config you should be able to go inside the config folder. Later you can move the paraview folder inside it. But you have to do this every time you start the app otherwise it freezes everytime. Hope this helps

Thank you. Unfortunately there is no ./config folder on my Mac. Now I am hoping for a new release of Preview that works on Monterey.

The actual directory path is ~/.config.

Thanks I found it. Any prediction when an update of Paraview will be available?

Is there a recent update of Paraview that works with MacOS Monterey without freezing?

ParaView 5.10 was released a couple weeks ago: ParaView 5.10.0 available for download

1 Like