Paraview not opening data from OpenFoam

Hi everyone!

I’m pretty new to OpenFoam and paraview, and I got everything I needed installed and everything appears to work fine, except I run into an issue when launching ParaView with the ‘paraFoam’ command.

I’m running Windows 10, and I followed this guide exactly:


So I’m running a linux shell with UBUNTU 18.04 LTS, and Paraview was installed through Ubuntu and with Xming.

I tried a very basic tutorial to see if my install was working properly:
https://cfd.direct/openfoam/user-gui…ty/#x5-40002.1

But when I launch paraview with the command ‘paraFoam’, I get the following readout:

Created temporary ‘cavity.OpenFOAM’
QStandardPaths: XDG_RUNTIME_DIR not set, defaulting to ‘/tmp/runtime-[user]’
failed to get the current screen resources
I/O : uncollated

Paraview opens and will display the model, but the data doesn’t load in.
I’ve been trying to figure this out for the past few days, but unfortunately I’m not the most computer savvy.
Sorry if this isn’t a Paraview problem, I just figured I might try asking here.
I’ve also posted this question here:
https://www.cfd-online.com/Forums/openfoam-installation/230216-paraview-does-not-open-data.html#post782705

Any help would be greatly appreciated!

As you point out, paraFOAM is not ParaView.

I would suggest trying with ParaView proper to see if you still have the issue.
https://www.paraview.org/download/