Plot over line gives NaN

Hi all!

I’m experiencing a little issue here when plotting over line. When I try to visualise the attached data in 2D everything works well. But if I want to plot, say on the x=0 axis, some values don’t appear (wholes in the line) whereas they appear on the 2D visualisation.

Any idea ?

Thanks guys!

data.rar (3.4 MB)

It is working great here. Can you provide a step by step to reproduce the issue ?

1- plot over line
2- set the line on the y axis
3- set the x coordinates of both ends to 0
4- apply
On the new window you should see a plot.

Now see that the line has 2 holes (that shouldn’t be there…)
5- export the data to .csv and you should see NaN values

Also note that these “holes” disappear if you set the x position of the line on -1e-9 for example.

1 Like

that a problem when the line is exactly on the edge. I would suggest using “Ctrl+P” to find the right position for the line?.

1 Like

Tried that, but it crashed for some reason

Looks like a bug. does 5.7.0-RC1 fixes it ?

Unfortunately not

Any output in the terminal ?


Well, unless you can provide more info, you will have to carefully set your line position.

I’m afraid I can’t. Now that I found a workaround it’s okay but this is a mystery to me. Have you managed to reproduce it ?

Not at all. If you want to investigate the issue yourself, you will have to build ParaView in debug and run it with a debugger. Not an easy task unless you are a programmer.

That’s strange cause the same thing happens on two of my computers.
I’ll see if I can find time to investigate a bit further though

Remi, if you can post your data in a different format, such as a .tar.gz, I will take a look.

What about that ?
temperature.xdmf (681 Bytes)
temperature.h5 (379.3 KB)

Same thing happens on this data.

The problem is that you are trying to plot right on the edge of your mesh, and numerical inaccuracies are causing points of the line to be outside of your mesh. (This is not a criticism of your data. Rather, this is just the nature of floating point numbers on a computer.)

Take a look at this captured screenshot. Here I have zoomed in the mesh at one of the places where the Plot Over Line is giving a NaN value. (It is the topmost point in the mesh and the rightmost point in the plot.) Then I have selected 3 mesh points around that location and I’m showing the numeric information for those 3 points in the superimposed Find Data dialog.

You can see that although the points with ids 387 and 713 have an x coordinate value of 0. However, the point with id 8 (which happens to be in the middle) has x coordinate value of -1.71663e-16. This is just slightly to the left of the line you are plotting on. The difference is imperceptible and I’m sure below any realistic significant digits. However, it means that when Plot Over Line intersects the line around those mesh cells, it computes it as just outside the boundary of the mesh, and thus assigns NaN values (which is the correct behavior).

The solution is simple. Move the line to the left by an epsilon amount so that it is always inside the mesh. I changed the x coordinate of both Point 1 and Point 2 to be -1e-15, and that seemed to work just fine as shown in this second screen capture.

Hi Kenneth ! Thanks for the help ! I was starting to imagine that the reason was something like that. I’ll find a solution for a better meshing.
I found that trick of moving an epsilon to the left but couldn’t figure why it worked: now I do!

Thank you all !!