Pls Help macOS: Error could not load Qt platform plugin "xcb" even though it was found

I’m trying to download open foam following the instructions on Download OpenFOAM v8 | macOS | OpenFOAM – OpenFOAM

  1. Downloaded Docker [successful]
  2. Downloaded XQuartz (XQuartz-2.8.1) [successful]
  3. Created an openfoam directory to later store pitzDaily [successful]
  4. Installed openfoam-8macos (using commands in step 3 on [successful]
  5. Downloaded ParaView-5.9.1-MPI-OSX10.13-Python3.8-64bit.pkg [successful]
  6. Launched open foam with ParaView (using commands in step 6 on open [successful]
  7. Testing openfoam8-macos (using commands in step 7 on open [–ERROR–]

Error Faced: When executing the final command paraFoam the following error pops up-

“qt.qpa.plugin: Could not load the Qt platform plugin “xcb” in “” even though it was found. This application failed to start because no Qt platform plugin could be initialized. Reinstalling the application may fix this problem.
Available platform plugins are: eglfs, linuxfb, minimal, minimalegl, offscreen, vnc, xcb.”

How can I resolve this issue? Any help is appreciated :(:frowning:

About this Mac: MacBook Air (Retina, 13-inch, 2019) Processor 1.6 GHz Dual-Core Intel Core i5 Memory 8 GB 2133 MHz LPDDR3 Startup Disk Macintosh HD Graphics Intel UHD Graphics 617 1536 MB

Not a ParaView issue (as I already pointed to you on reddit).

Do not use ParaFOAM, use ParaView:

Ive tried these suggestions but it didn’t work for me, that’s why I posted here for more opinions. Tried paraFoam -vtk or paraFoam -builtin didn’t work. Tried to load my open foam file directly into Paraview didn’t work as it said the file couldn’t be read.

Share your data.