Problem about paraviewweb configuration


(yancheng) #1

Hello,
I’m trying to configure the paraviewweb enviroment on Ubuntu 18.04.
Single user mode is very simple and succeed.
Multiple user mode has note been success until now~
I mainly follow this instruction: http://kitware.github.io/paraviewweb/docs/ubuntu_14_04.html
I have test many version of paraview, result as follows:
First, all version of paraview desktop bin file can be open, but is black and empty


Second, version 5.2, 5.4, 5.5.1 can go to the final step, one paraview window can prompt, but the webpage is empty.

Third, version 5.3 come across problem when running ./start.sh, problem information is about “can note find vtkCommonCorePython”.
So where is my problem, thank you all~


(yancheng) #2

Again, I install Ubuntu 18.04 on a new Workstation.
Configure paraviewweb using version 5.2.
I modify the index.html as follows:


Then I input in the chrome browser as follows:
http://192.168.2.153/visualizer/?data=can.ex2
Then the webpage is still empty, but the prompted paraview window can load the data:

So I really don’t know where is the problem? Need your help, thank you~


(Sebastien Jourdain) #3

It seems that your launcher configuration works as the ParaView process properly start, but it seems that the client side either error out or does not fully load.

First of all, the edit that you’ve done on the main page are not necessary (getUrlParameter) as that feature is now embedded inside Visualizer when you call `Visualiser.connectWithArgsAsConfig({ … }).

  1. How did you get ParaView? Did you built it (repo or superbuild) or used a prebuilt version from our web site?

  2. How did you get Visualizer? Did you built it or used the one inside the bundle of ParaView (from our binaries). And which version if built?

  3. What does the line sessionURL looks like in your launcher configuration?

And hopefully with the answer with those 3 questions, I should be able to help you.


(Sebastien Jourdain) #4

BTW, we have docker images that can be used which already have the multi-user setup. See for more details.

But to properly leverage your GPU, you will need an NVidia GPU.


(yancheng) #5
  1. I download the binary version 5.2.0 from your website
  2. I used the one inside the bundle of paraview 5.2.0
  3. sessionRUL like this

“sessionURL” : “ws://192.168.2.153:80/proxy?sessionId=${id}&path=ws”,
or
“sessionURL” : “ws://www.paraview.com:80/proxy?sessionId=${id}&path=ws”,

both not work


(yancheng) #6

BTW, I find that in win10 configuration doc, there is more than one line:
“content”: “<paraview-root>/share/paraview-5.2/web/visualizer/www”,
so, I also add this line to the configuration file on Ubuntu, but still not work


(Sebastien Jourdain) #7

Can you open the development tab of your browser to see if any error show up?

I’m guessing the apache module for WebSocket tunneling have been properly installed and the rewrite rule is correct?

Also does the proxy.txt written by the launcher accessible by the apache user?


(yancheng) #8

Do you mean that if I want to configure paraviewweb for multi-user mode, I can directly use the EC2 system? And it’s more simple for configuration ?


(Sebastien Jourdain) #9

I’m just saying that if you are not familiar with setting up all those processes, users and network configuration, the EC2 guide reduce the amount of work you need to do on your machine as the full setup has been made inside a Docker image.

But in that setup, you won’t have access to the launcher config so loading a file at startup won’t be easy unless you build your own docker image where you override that launcher configuration file using the same base one as ours. It is fairly easy to do as long as you are familiar with Docker.

But I feel you are pretty close to get your current setup working.

BTW, did you patch the code to make the Visualizer compatible with ParaView like described here?


(yancheng) #10

I try once again in browser, the screenshot is as follows:


In the right console window, I restart apache2, left console windows running start.sh
when I input the url, one paraview window prompt, and in the development tab of my firefox browser, a error is shown: firefox can not connect to the url of server.


(Sebastien Jourdain) #11

BTW with the latest ParaView, it is expected that the image/window you see remain black. That does not mean the actual rendering properly happen.

It is just that the Offscreen system works a differently/better.


(Sebastien Jourdain) #12

Good that means that Apache is not forwarding the WebSocket connection.

Can you show the result of ls -al /full-path-to/proxy.txt?


(Sebastien Jourdain) #13

Also what is your Apache config? (Want to validate the path to proxy.txt)


(yancheng) #14

image


(Sebastien Jourdain) #15

Then it is expected that the Apache process can not read that file…

You skipped the security part in the documentation.


(yancheng) #16

my directory structure is the same as the doc instruction.


(Sebastien Jourdain) #17

You have that structure under your home directory, not at the root (/) or /opt.

Now Apache need to be able to go through all those directory as a Daemon user… You need to start playing with groups and users while adjusting your directory/files rights…


(yancheng) #18

you mean that I skip this section ? I should follow this section completely so that it can works ?


(Sebastien Jourdain) #19

Yes although you can tweak it by doing that with your user as long as you understand what you are doing.

The goal is to allow the Apache process to read that proxy.txt file while the user that run the launcher should be able to write it and run ParaView while using your GPU while not being a power user…


(yancheng) #20

ok, I add a pvw-user in root dir
image
And then I modify the directory stucture and all the path in configuration file, it is expected to work?