Ray Traced Particles scaling with stress

I have imported a vtk file showing a block of particles being drilled with a screw. As soon as I turned the Ray Traced Rendering on, I noticed the size of the particles are changing either with respect to time or wrt to avg stress being applied. At any given time the particles are of the same size. As stress is applied the particles enlarge. However, at time stamps when the force seems to be a bit low all the particles become smaller.
Please note that the “Ray Tracing → Scale Array” is NOT ticked.
How do I prevent the particles from being scaled with ray traced rendering?

Share a screenshot ?

Here you go - animation frames at 20-frame intervals, showing that the scaling option is off.

please press Apply.

In any case, I do not see any kind of scaling within ParaView or OSPray, can you do a side by side comparison highlighting the issue ?

Sure, done. Here is a video showing the progression through frames 0-100. The particles appear to grow and shrink significantly in diameter as the frames progress. Focus on the top left corner of the cube in order to notice it most easily. Thanks!

Unless I’m mistaken, this is coming from your data, not from ParaView

@mconti has experienced similar behavior:


1 Like

I agree with Ted - try the “All Exact” or “Each Exact” scaling modes that are new in PV 5.9 or so.

The original and still default behavior scales the radii based on a heuristic that takes into account the data bounding box. The bounds changes over time here and the the spheres scale a bit.


Thanks! I’ll look into it.

So, it may have been an error in my input file. Anyways we sort of found a fix by adding a clipping plane just above and below the block and it follows it as the box moves.