Removing background when exporting .png, .eps or .svg

Hello! I am trying to export the plots that I’ve made on Paraview in .png, .eps or .svg format. When I do so, the blue-greyish background is “exported with it”. I’d like to be able to export my plot alone with no background (or alternatively be able to turn the background white with no shadows). I’ve tried to remove the background by unchecking the “Draw background” and “Rasterize 3D geometry” checkboxes in the Export Options dialog that appears after setting the filename. However, this causes a problem and a dialog box saying “Ignoring DrawBackground=false setting. The background is always drawn on the OpenGL2 etc…” pops up. Any ideas on how I can export the objects in my plot alone and not the background? Thanks!

1 Like

There is an option to set the background color or to make it transparent after selecting where to save your screenshot. See this:

which yields:

1 Like

Thank you very much, really appreciate it! It all worked.

1 Like

Hi, I’m having the same issue as the OP. Unfortunately, the solution suggested doesn’t seem to include .svg files (unless I’ve missed something obvious!) - is there something else I can try?

Many thanks!

Unrelated question. Please open your own thread if you have more questions.