Removing background when exporting .svg images


I am trying to remove the background from my .svg images. I’m fairly certain after checking the OP of this question again, that it is actually related!

I’m using File --> Export Scene to bring up a save file dialogue window (which in v5.8.0 seems to still have .svg export capabilities). On typing in a filename, the next popup gives the option to uncheck ‘Draw background’ but on clicking Save, I get the following error:

( 308.467s) [paraview        ]vtkOpenGLGL2PSExporter.:102   WARN| vtkPVGL2PSExporter (0x198919a0): Ignoring DrawBackground=false setting. The background is always drawn on the OpenGL2 backend for GL2PS exports.

I’ve attached some screenshots of the process and error.
Is there another way to export svg images with transparent backgrounds? It doesn’t seem to be available under File --> Save Screenshot, which I think @mwestphal might have been referring to regarding an inability to. save svg files.

Many thanks and kind regards.

You are right, this used to be possible but it is not anymore.

If you save as a .png you should be able to save with a transparent background.

Thanks for your reply. Is svg support being abandoned?

not directly, but .svg support was reduced for different OpenGL related reasons. It will stay like this.

I see. Shame that there’s no vector graphics support but it imagine it’s a lot of formats to stay on top of! Thank for the clarification.