Transient Simulation with .VTP and .PVD

I want to apologize if this is already posted on another thread.

I’m new using Paraview and I need to create an output module with Fortran 90 for a transient simulation. Since I’m just starting to use Paraview I’m trying with a very easy code in .f90.
I created a total of 10 different frames which are written under the names “temperaturas_1.vtp”, “temperaturas_2.vtp”… “temperaturas_10.vtp”, and each of them has written the following on it.

ZONE T=" 0.1000000 "I= 4.000000 J= 4.000000
0.2500000 0.2500000 0.1000000
0.5000000 0.2500000 0.1000000
0.7500000 0.2500000 0.1000000
1.000000 0.2500000 0.1000000
0.2500000 0.5000000 0.1000000
0.5000000 0.5000000 0.1000000
0.7500000 0.5000000 0.1000000
1.000000 0.5000000 0.1000000
0.2500000 0.7500000 0.1000000
0.5000000 0.7500000 0.1000000
0.7500000 0.7500000 0.1000000
1.000000 0.7500000 0.1000000
0.2500000 1.000000 0.1000000
0.5000000 1.000000 0.1000000
0.7500000 1.000000 0.1000000
1.000000 1.000000 0.1000000

changing only the last column which represents the temperature values.

To read multiple files I also wrote a .pvd file based on this example Transient Simulation- Files in Tecplot Format.

My PVD file contains:

 <VTKFile type="Collection" version="0.1" byte_order="LittleEndian" header_type=
  <DataSet timestep="0.1" part="0" file="TEMPERATURAS_1.vtp  "/>
  <DataSet timestep="0.2" part="0" file="TEMPERATURAS_2.vtp  "/>
  <DataSet timestep="0.3" part="0" file="TEMPERATURAS_3.vtp  "/>
  <DataSet timestep="0.4" part="0" file="TEMPERATURAS_4.vtp  "/>
  <DataSet timestep="0.5" part="0" file="TEMPERATURAS_5.vtp  "/>
  <DataSet timestep="0.6" part="0" file="TEMPERATURAS_6.vtp  "/>
  <DataSet timestep="0.7" part="0" file="TEMPERATURAS_7.vtp  "/>
  <DataSet timestep="0.8" part="0" file="TEMPERATURAS_8.vtp  "/>
  <DataSet timestep="0.9" part="0" file="TEMPERATURAS_9.vtp  "/>
  <DataSet timestep="1.0" part="0" file="TEMPERATURAS_10.vtp "/>

When I try to open my files on Paraview I have a little problem with the time step in the time display. There’s must be 10 different time steps (from 0 to 9) but It appears 18 (19 in total), where the first 10 are from 0.1 to 1.0 [s] and don’t change the frame, and the other 9 are from 1.0 to 9.0 changing the frames.


I don’t know if there is a problem openning the file or creating it.
I would be thankful if anyone could help me.

Thanks in advance.

Once I remove the spaces at the end of the filenames, everything works great.


Maybe you have another temporal dataset open in ParaView ?

Thank you so much for your fast reply.

I tried deleting the last space in the file name and I still have the same problem.
I don’t have another dataset open in Paraview, I close the program and then I open it again to prove another dataset.

I don’t know if this could help to find a solution but I wrote .vtp files and .pvd one in the same directory. I open them simultaneously (10. vtp + 1.pvd) with “Tecplot Reader”.

please share your whole data.

Sure. Here are my vtp files and the pvd one.

TEMPERATURAS_1.vtp (865 Bytes)
TEMPERATURAS_2.vtp (865 Bytes)
TEMPERATURAS_3.vtp (865 Bytes)
TEMPERATURAS_4.vtp (865 Bytes)
TEMPERATURAS_5.vtp (865 Bytes)
TEMPERATURAS_6.vtp (865 Bytes)
TEMPERATURAS_7.vtp (865 Bytes)
TEMPERATURAS_8.vtp (865 Bytes)
TEMPERATURAS_9.vtp (865 Bytes)
TEMPERATURAS_10.vtp (865 Bytes)
time.pvd (812 Bytes)

I’m openning them at the same time with Tecplot Reader. I have ParaView 5.6.0 installed on my pc.

Thank you for your help.

This doesn’t make sense, these files are not Tecplot files.

I have ParaView 5.6.0 installed on my pc.

Please test with the last release of ParaView, 5.9.1.

Hi Diego,

If you are going to use the tecplot format as is, it might be easier to set the real time in the meta file than in the pvd file. For example, you can load the file “TEMPERATURAS.tec.series” included below directly into ParaView. (3.3 KB)

Thank you for your answer, Mathieu. I tried downloading the latest release of Paraview and I still have the same problem. The only difference is that Paraview shows errors now, that must be because I was opening the files with Tecplot Reader.

Thank you for your help and time, I was able to open the files with .tec.series and Tecplot Reader, which is fine for me.

Hi Kyoshimi,
thank you for your help. It works successfully.