Using Surface LIC: Attempt to get an input array for an index that has not been specified


I’m trying to vizualize the velocity field of my CFD OpenFOAM results with the LIC addon.
In previous cases the visualization with LIC worked as expected.
I my current case, selecting “surface LIC” in Paraview, I’m getting the error:

Attempt to get an input array for an index that has not been specified

In the render window I’m getting weird grey blocks.

This issue was already mentioned here and here.
As mentioned in previous discussions, LIC expects the scalars_ field to be of dimension 3.
However in my case the scalars_ fields is of dimension 4.
My questions are:
How could the scalars_ fields differ in its dimensions using OpenFOAM?
And how can a Paraview user can solve this issue, e.g. change the scalars_ dimension?

I’ve also added a vtp file to better coprehend the case: (3.6 MB)

Use the calculator filter to create a 3 component vector using your 4 component field.

thank you for your reply!
When executing U[:,:3] in the Python calculator, I don’t get the error message, but the rendering window still shows weird blocks:

view screenshot

Here is how it looks here, I do not see the blocks:

Having tried it on another machine where it worked too,
I now think it is a problem on my machine.
When I save the state on the working machine and open it on the failing system, I can view the LIC.
But when I normally open the case.foam on that machine, I’m getting those weird blocks.

Still I do not understand, why I could use LIC without problems in the previous time.
Unloading and loading the plugin doesn’t help either :frowning:
I’m using Paraview 5.9.1 on Ubuntu 20.04.2 LTS.

solved it by resetting paraview, must’ve been a weird setting constellation.