VR plugin with Oculus Quest 2


I’m using the Oculus Quest 2 with Paraview (V5.10.1) and when I enable the openVR plugin and send the view to the headset I’m presented with a blank, black space within the headset. The VR view from Paraview does show the headset is tracking and shows the models I have loaded.

Is there a step I’m missing or is the quest 2 not supported?

Mark Howell
University of Utah School of Biological Sciences

@martink @Scott_Wittenburg @Tiffany_Chhim

Quest 2 is supported, but it has been a while since I tested that specific headset. Let me load it up today and see.

I appreciate the quick response, let me know if you need any more info about my hardware setup.

My local build/install of master works fine. My install of PV5.10 RC 1 is missing the manifest files but otherwise works. I feel like the missing manifest files issue popped up recently here. Let me dig around.

Found the issue relevant to RC1. specifically here https://gitlab.kitware.com/paraview/paraview/-/issues/21004

Is that what you are seeing? If so the fix is merged months ago but maybe you are running a different PV build or download?

I misspoke earlier, I’m running 5.10.0. It looks like the opposite of that bug, in the headset I only see a black room with my guardian on the floor. When I turn on the VR view on the desktop I see that the headset is properly tracking and my controls are working but nothing gets displayed on the Oculus Quest.

Hmm. You should be hitting the button “Send To OpenVR” to get into VR and make sure you have Steam + SteamVR installed with the occulus support. I start the occulus app, first, turn on link, then start steamVR and make sure your headset is showing up.

I think it might be a hardware related issue. Both my PI and I both had the same issue with getting a black screen on the quest after sending it to openVR using our laptops (with nvidia 2070 supers) but it works just fine on my lab machine with a 2080. I’ll do some more troubleshooting to see if I can root out a cause.

Might want to run paraview and hit Help → About scroll down to OpenGL and make sure the laptop is using your 2070s and not the generic APU

That was it! After forcing it to use the GPU it shows up just fine in the headset.

Thanks so much for you help.

Awesome! Grad to hear it.