Enabling ray tracing with glyphs

Whenever I click on “Enable Ray Tracing” and I have a Glyph object in my scene, a big object appears out of nowhere:


I am referring to the ball and the cone in the bottom left. Is this somehow a light used by the ray tracing? How can I make it invisible? Thanks.

This bug has to do with the vtk widgets that are placed into the scene that you normally use to do things like move a clipping plane or place a line segment or whatnot that the filters use. VTK’s interaction widgets are not hooked up correctly yet in many cases in the VTK/Renderering/RayTracing code path yet unfortunately and that causes bugs like this one.

You might try disabling the widgets in the properties tab. For instance the clip and slice filters have a “Show Plane” button on them. Note that there is a related bug where you may have to turn off the visibility before turning on ray tracing.

@utkarsh.ayachit - this is an example of what we were talking about the other day.

Thanks for your response. I have a clip operation (box) that seems to be the source of the problem. However, disabling the widget (“Show Box”) does not make the artificial object go away. I have tried several combinations of turning off the visibility and the ray tracing, but none of them works. I am using paraview 5.8.0

cc: @berkgeveci

Can you provide data & steps to reproduce? I tried a few things but could not reproduce. Thanks.