no text appears in the pop-up windows, when moving the cursor on filters

Dear all,

I am using paraview on a virtual macine (VM-ware). My problem is not a big issue, however it would be great if this problem could be fixed.

When I move my cursor on arbitrary filters (e.g. Clip, Rescale, Warp by Scalar,…) usually a small window pop-ups and shows some explanation what the correspondong filter actually does. In my case, the window pop-ups, but without the additional helping text, i.e. just an empty white window.
If necessary, I can attach a screenshot, but I guess my problem is well described.

Here some additional input about my current OpenGL settings:
OpenGL Vendor: VMware, Inc.
OpenGL Version: 2.1 Mesa 20.0.8
OpenGL Renderer: SVGA3D;build;RELEASE; LLVM;

I am not quite sure if this is actually a problem related to OpenGl/Missing drivers or if there is a simple setting inside paraview where I can activate the “helping texts”.

Any input would be greatly appreciated!


Not sure which window you are talking about. This information is displayed in the info status bar:

I attached a screenshot of what I am talking about. So for instance I move my cursor on the icon to change the background, then the little white rectangle pop-ups, but in my case it is not filled. (Usually the rectangle is filled with some text what the icon or filter does). I have this problem with all filters,…

Is it clear now what I mean?


Looks like a graphic driver / Qt bug. This would require deeper investigation in order to figure out what is going on.

Can you give me some catchwords where the problem may comes from respectively in which files,… I can have a look to may fix my problem?

It would be very helpful to me, if the helping texts were available.

“Qt tooltip do not appear” in google gives some insight.

What I’d do in your case would be building a simple qt app with tooltip to make sure this is a qt issue, not a ParaView one.

Thank you, I will give it a try!

I have seen that I use QT version 4.8.7. I guess this could be the problem, since it is recommended to use a higher version.

Is there a way to install paraview via “sudo apt install paraview” with the current QT-version? I have installed a newer version of QT manually. However reinstalling paraview in the described way doesn´t recognize my new version of QT, i.e. there is still version 4.8.7

Just downlowd paraview from here:

I tried to install paraview manually as you suggested, however cmake is reporting some error messages:

You have answered a similar question already in this forum where someone had the very same problem. After that error message I called cmake via:

cmake -DQt6_DIR=<Path/to/my/downloaded/version> …/paraview

Unfortunately the error message is not gone. I am not quite sure if my downloaded Qt, which I pass to cmake, is correct. Here is a screenshot of the folders I got after extracting Qt6:

Inside this folder I passed the cmake folder to cmake via -DQt6_DIR=… Is this correct?
By the way, the cmake error wants “Qt5 external dependency”, however I downloaded Qt6. Can this be a problem as well?

Not sure why you think you need to compile ParaView yourself.

Just download and use it:

I can open paraview now, but there is still a issue related to OpenGl:

I am running paraview on a virtual machine (vmware workstation player 16). On my host operating system, which is windows10, my graphic card model is “NVIDIA GeForce Rtx 2080”, OpenGL version 4.6.

Do you know if the workstation player of vmware supports a higher version of OpenGl than version 2.1? I know that within the pro-version there is a setting to support higher versions but I didn´t find a similar setting for the player-version.


Use mesa as described here:

I am running paraview on a linux distribution (ubuntu), i.e. my host is windows10 and my guest system is ubuntu and I run paraview in ubuntu.

Is there a similar approach as described in your article? In there only the implementation for windows10 is shown.

Why not using ParaView outside of the VM, in Windows ?

In any case, yes and no, you can build mesa to do that but there is no mesa binary for your case.